summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2021-07-10 14:10:15 +0300
committerMart Raudsepp <leio@gentoo.org>2021-07-10 14:27:30 +0300
commit9e677777f74fe8170ff44277d2e64e24a61c7ec8 (patch)
tree44c61af3c09f5a620d95efd91e2e771568659ef1 /x11-libs/pango
parentmedia-video/makemkv: Bump to 1.16.4, drop old 1.16.3 (diff)
downloadgentoo-9e677777f74fe8170ff44277d2e64e24a61c7ec8.tar.gz
gentoo-9e677777f74fe8170ff44277d2e64e24a61c7ec8.tar.bz2
gentoo-9e677777f74fe8170ff44277d2e64e24a61c7ec8.zip
x11-libs/pango: use pregenerated docs, correct CFLAGS, other touchups
* Replicate release or debug build types like in dev-libs/glib via USE=debug; this may be important for release build performance and upstream expects it done while forcing downstreams to worry about it if -Dbuildtype=plain is used * Install pre-generated API docs instead of regenerating them with a gi-docgen build dep; upstream puts them into the tarball since 1.48.5 * Sort deps and meson options in the order they appear, remove double dep of libXrender * Drop redundant IUSE=test * Drop unnecessary gnome2_schemas_update call, as pango ships no schemas * Fix LICENSE to not contain FTL anymore. It containing code licensed under FreeType license doesn't appear to be true since around v1.28 as the relevant code moved to HarfBuzz and eventually got relicensed to MIT - see https://lwn.net/Articles/265375/ Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'x11-libs/pango')
-rw-r--r--x11-libs/pango/pango-1.48.7-r1.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/x11-libs/pango/pango-1.48.7-r1.ebuild b/x11-libs/pango/pango-1.48.7-r1.ebuild
new file mode 100644
index 000000000000..306afbbf4a59
--- /dev/null
+++ b/x11-libs/pango/pango-1.48.7-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic gnome2-utils meson-multilib toolchain-funcs xdg
+
+DESCRIPTION="Internationalized text layout and rendering library"
+HOMEPAGE="https://www.pango.org/ https://gitlab.gnome.org/GNOME/pango"
+SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/pango/$(ver_cut 1-2)/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="debug +introspection sysprof X"
+
+RDEPEND="
+ >=dev-libs/glib-2.62.2:2[${MULTILIB_USEDEP}]
+ >=dev-libs/fribidi-0.19.7[${MULTILIB_USEDEP}]
+ >=media-libs/harfbuzz-2.0:=[glib(+),introspection?,truetype(+),${MULTILIB_USEDEP}]
+ >=media-libs/fontconfig-2.12.92:1.0=[${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.12.10:=[X?,${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1:2=[harfbuzz,png,${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXft-2.3.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4[${MULTILIB_USEDEP}] )
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="
+ dev-util/glib-utils
+ sys-apps/help2man
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_src_prepare
+ gnome2_environment_reset
+}
+
+multilib_src_configure() {
+ if use debug; then
+ append-cflags -DPANGO_ENABLE_DEBUG
+ else
+ append-cflags -DG_DISABLE_CAST_CHECKS
+ fi
+
+ local emesonargs=(
+ # Never use gi-docgen subproject
+ --wrap-mode nofallback
+
+ -Dgtk_doc=false # we ship pregenerated docs
+ $(meson_native_use_feature introspection)
+ -Dinstall-tests=false
+ -Dfontconfig=enabled
+ $(meson_feature sysprof)
+ -Dlibthai=disabled
+ -Dcairo=enabled
+ $(meson_feature X xft)
+ -Dfreetype=enabled
+ )
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ insinto /usr/share/gtk-doc/html
+ # This will install PangoXft API docs regardless of USE=-X, but this is intentional
+ doins -r "${S}"/docs/Pango*
+}