summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-01-16 15:51:25 -0500
committerSam James <sam@gentoo.org>2024-01-17 06:33:41 +0000
commit376a36b9e7b86753960609c80becee74cb40b83b (patch)
tree3737d5ce5e0489ff771e800a767666bdeffdf7bf /x11-libs/libXaw
parentwww-client/links: reduce USE=X dependency to the minimum requirement (diff)
downloadgentoo-376a36b9e7b86753960609c80becee74cb40b83b.tar.gz
gentoo-376a36b9e7b86753960609c80becee74cb40b83b.tar.bz2
gentoo-376a36b9e7b86753960609c80becee74cb40b83b.zip
x11-libs/libXaw: remove runtime dependency on xorg-proto
xorg-proto is never a runtime dependency of software, always a build-time only dependency. It provides headers and pkg-config files alone. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-libs/libXaw')
-rw-r--r--x11-libs/libXaw/libXaw-1.0.15-r1.ebuild (renamed from x11-libs/libXaw/libXaw-1.0.15.ebuild)9
1 files changed, 6 insertions, 3 deletions
diff --git a/x11-libs/libXaw/libXaw-1.0.15.ebuild b/x11-libs/libXaw/libXaw-1.0.15-r1.ebuild
index ab0dd22d5546..d764114b30eb 100644
--- a/x11-libs/libXaw/libXaw-1.0.15.ebuild
+++ b/x11-libs/libXaw/libXaw-1.0.15-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,13 +13,16 @@ DESCRIPTION="X.Org Xaw library"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="deprecated"
-RDEPEND="x11-base/xorg-proto
+RDEPEND="
>=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
>=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
>=x11-libs/libXmu-1.1.1-r1[${MULTILIB_USEDEP}]
>=x11-libs/libXpm-3.5.10-r1[${MULTILIB_USEDEP}]
>=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]"
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
src_configure() {
local XORG_CONFIGURE_OPTIONS=(