summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Hoffstätte <holger@applied-asynchrony.com>2024-09-12 16:07:13 +0200
committerPacho Ramos <pacho@gentoo.org>2024-09-15 14:24:59 +0200
commit4f79cdcc9f9f1d131994a0764d0dc3e1d9a5fbad (patch)
tree4a2baaee39bdf7229a16b9d228e6c5b78a02ad60 /x11-libs/gtksourceview
parentdev-util/codeblocks: fix HOMEPAGE permanent redirection (diff)
downloadgentoo-4f79cdcc9f9f1d131994a0764d0dc3e1d9a5fbad.tar.gz
gentoo-4f79cdcc9f9f1d131994a0764d0dc3e1d9a5fbad.tar.bz2
gentoo-4f79cdcc9f9f1d131994a0764d0dc3e1d9a5fbad.zip
x11-libs/gtksourceview: fix compilation of 2.10.5 with gcc-14
Also use consistent patch names. Closes: https://bugs.gentoo.org/937626 Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com> Closes: https://github.com/gentoo/gentoo/pull/38579 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-libs/gtksourceview')
-rw-r--r--x11-libs/gtksourceview/files/2.10.5-G_CONST_RETURN.patch (renamed from x11-libs/gtksourceview/files/gtksourceview-2.10.5-G_CONST_RETURN.patch)0
-rw-r--r--x11-libs/gtksourceview/files/2.10.5-gcc14.patch21
-rw-r--r--x11-libs/gtksourceview/gtksourceview-2.10.5-r3.ebuild5
3 files changed, 25 insertions, 1 deletions
diff --git a/x11-libs/gtksourceview/files/gtksourceview-2.10.5-G_CONST_RETURN.patch b/x11-libs/gtksourceview/files/2.10.5-G_CONST_RETURN.patch
index d42feacd3e3f..d42feacd3e3f 100644
--- a/x11-libs/gtksourceview/files/gtksourceview-2.10.5-G_CONST_RETURN.patch
+++ b/x11-libs/gtksourceview/files/2.10.5-G_CONST_RETURN.patch
diff --git a/x11-libs/gtksourceview/files/2.10.5-gcc14.patch b/x11-libs/gtksourceview/files/2.10.5-gcc14.patch
new file mode 100644
index 000000000000..e86cfbc7d60f
--- /dev/null
+++ b/x11-libs/gtksourceview/files/2.10.5-gcc14.patch
@@ -0,0 +1,21 @@
+
+Fix build with gcc-14.
+
+Backported version of patch from:
+https://gitlab.gnome.org/GNOME/gtksourceview/-/commit/b25e71c57fc934a7ce36e51826af9fa7c2cf9a80
+
+Bug: https://bugs.gentoo.org/937626
+
+Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com>
+
+--- gtksourceview-2.10.5/gtksourceview/gtksourceview.c 2010-08-22 13:45:05.000000000 +0200
++++ gtksourceview-2.10.5-gcc14/gtksourceview/gtksourceview.c 2024-08-09 16:11:37.319493797 +0200
+@@ -1766,7 +1766,7 @@ set_source_buffer (GtkSourceView *view,
+
+ if (buffer && GTK_IS_SOURCE_BUFFER (buffer))
+ {
+- view->priv->source_buffer = g_object_ref (buffer);
++ view->priv->source_buffer = g_object_ref (GTK_SOURCE_BUFFER (buffer));
+
+ g_signal_connect (buffer,
+ "highlight_updated",
diff --git a/x11-libs/gtksourceview/gtksourceview-2.10.5-r3.ebuild b/x11-libs/gtksourceview/gtksourceview-2.10.5-r3.ebuild
index c238975c90d7..5dc42f20caa8 100644
--- a/x11-libs/gtksourceview/gtksourceview-2.10.5-r3.ebuild
+++ b/x11-libs/gtksourceview/gtksourceview-2.10.5-r3.ebuild
@@ -31,7 +31,10 @@ BDEPEND="
DOCS=( AUTHORS ChangeLog HACKING MAINTAINERS NEWS README )
# Patch from 3.x for bug #394925
-PATCHES=( "${FILESDIR}/${P}-G_CONST_RETURN.patch" )
+PATCHES=(
+ "${FILESDIR}/2.10.5-G_CONST_RETURN.patch"
+ "${FILESDIR}/2.10.5-gcc14.patch"
+)
src_prepare() {
gnome2_src_prepare