summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-04-15 12:02:56 -0400
committerMatt Turner <mattst88@gentoo.org>2024-04-15 12:16:38 -0400
commitd40c0af6c5e73efe424c8f3215b83dba0034d41f (patch)
treef695d553b68390e54656e9d0b1e96d7960e06f0d /x11-drivers
parentx11-libs/libxcb: Version bump to 1.17.0 (diff)
downloadgentoo-d40c0af6c5e73efe424c8f3215b83dba0034d41f.tar.gz
gentoo-d40c0af6c5e73efe424c8f3215b83dba0034d41f.tar.bz2
gentoo-d40c0af6c5e73efe424c8f3215b83dba0034d41f.zip
x11-drivers/xf86-input-wacom: Version bump to 1.2.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-wacom/Manifest1
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-1.2.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-wacom/Manifest b/x11-drivers/xf86-input-wacom/Manifest
index 072015325a84..66e26fe8d140 100644
--- a/x11-drivers/xf86-input-wacom/Manifest
+++ b/x11-drivers/xf86-input-wacom/Manifest
@@ -1,2 +1,3 @@
DIST xf86-input-wacom-1.2.0.tar.bz2 647874 BLAKE2B c59e605bacb2694c2e322faba9b030112ffb57f916c816cbcb9a946fa063713c0590e1ea29273f73a84f4360b5bc5241c9768d7e61d77dfc9fb0af72b1a6f1cc SHA512 34817b87318d1fcf885e6427436a54d748a1c910026e6af0a22fafb461b227ca566cf06846f1f57c0d66412d5a3b20c95f014a71f8ef394ea8ca360a5f902318
DIST xf86-input-wacom-1.2.1.tar.bz2 655198 BLAKE2B 0597b9c4e05ddd696943e1a03eaf1543db78ba895d8ac3d29cf6fe0a185236eb522a8511a2757c5eb965e35283e2bd4c08e4416548de1f76456d0d27575f5eaa SHA512 b8fd8496bf297ac0e44f36e8d84131600b689e27f35368895795302d4fd60d83ae9da9773c71007cf4f2b1c02d1aec27280d789821f17c57ec47b988c4f4c3bb
+DIST xf86-input-wacom-1.2.2.tar.bz2 649132 BLAKE2B c068317c7ca74dbda336f12c96cf27f7541880aa75f65638d72755d28538614d72e091ca94a7c62c84e5748ebfa459fe3f930edcd55e53797301719630055e8f SHA512 60c490ff67ff6b4719a2683f5368ef3fca3d97ced92cf251bb4c7610d24e9df1d3577f50b625621025b2e2d1abf8f8aac2dbb7629220664992f6b85a0a84adcb
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-1.2.2.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-1.2.2.ebuild
new file mode 100644
index 000000000000..e355f2abb948
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-1.2.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info systemd udev xorg-3 meson
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="https://linuxwacom.github.io/"
+SRC_URI="https://github.com/linuxwacom/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXinerama
+ virtual/libudev:="
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present HID_WACOM; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " HID support --->"
+ ewarn " Special HID drivers --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ xorg-3_flags_setup
+
+ local emesonargs=(
+ -Dsystemd-unit-dir="$(systemd_get_systemunitdir)"
+ -Dudev-rules-dir="$(get_udevdir)/rules.d"
+ $(meson_feature test unittests)
+ -Dwacom-gobject=disabled
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}