summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-02-06 20:32:00 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-02-06 21:21:41 -0500
commit1d31c1c2f2808bce35615c3b445c70deaa039032 (patch)
tree8f3247fc16af600f0cbaf2730079c351a84f8630 /x11-drivers/nvidia-drivers/nvidia-drivers-535.154.05.ebuild
parentnet-misc/dhcpcd: Stabilize 10.0.6-r1 hppa, #923514 (diff)
downloadgentoo-1d31c1c2f2808bce35615c3b445c70deaa039032.tar.gz
gentoo-1d31c1c2f2808bce35615c3b445c70deaa039032.tar.bz2
gentoo-1d31c1c2f2808bce35615c3b445c70deaa039032.zip
x11-drivers/nvidia-drivers: move nvidia-powerd behind IUSE=powerd
Mostly due to the openrc service's "need dbus" which is an annoyance when dbus is missing (preventing from being a runtime-only optfeature), but even with systemd this now also allows to properly check for multilib on dbus (used by 32bit glcore/eglcore libraries to communicate with powerd). *Technically* needs a revbump given --changed-use does not know it needs to rebuild here, but given this only cause problems for rare users without dbus (e.g. headless cuda servers with USE=-tools) and will propagate with kernel updates+rebuilds let's not bother every users over this. Hopefully users of powerd (incl. for systemd which may have more existing ones) will notice the new USE and enable it. Also re-arrange arm64 handling, it makes more sense to mask the USE on arm64 than keep it as a no-op by checking if use !amd64. Exception to this is 0/550 branch which started to include a arm64 nvidia-powerd build (albeit do not think hardware that need this even exists yet). Hope did not break installation there given did not test on arm64, please report if so. Bug: https://bugs.gentoo.org/923117 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-drivers/nvidia-drivers/nvidia-drivers-535.154.05.ebuild')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-535.154.05.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-535.154.05.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-535.154.05.ebuild
index 38ad82d3c314..bde3618ee96a 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-535.154.05.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-535.154.05.ebuild
@@ -25,7 +25,7 @@ S=${WORKDIR}
LICENSE="NVIDIA-r2 Apache-2.0 BSD BSD-2 GPL-2 MIT ZLIB curl openssl"
SLOT="0/${PV%%.*}"
KEYWORDS="-* amd64 ~arm64"
-IUSE="+X abi_x86_32 abi_x86_64 kernel-open persistenced +static-libs +tools wayland"
+IUSE="+X abi_x86_32 abi_x86_64 kernel-open persistenced powerd +static-libs +tools wayland"
REQUIRED_USE="kernel-open? ( modules )"
COMMON_DEPEND="
@@ -58,6 +58,7 @@ RDEPEND="
x11-libs/libX11[abi_x86_32(-)?]
x11-libs/libXext[abi_x86_32(-)?]
)
+ powerd? ( sys-apps/dbus[abi_x86_32(-)?] )
wayland? (
gui-libs/egl-gbm
>=gui-libs/egl-wayland-1.1.10
@@ -156,7 +157,8 @@ src_prepare() {
sed 's/__USER__/nvpd/' \
nvidia-persistenced/init/systemd/nvidia-persistenced.service.template \
> "${T}"/nvidia-persistenced.service || die
- use !amd64 || sed -i "s|/usr|${EPREFIX}/opt|" systemd/system/nvidia-powerd.service || die
+ use !powerd || # file is missing on arm64 (masked)
+ sed -i "s|/usr|${EPREFIX}/opt|" systemd/system/nvidia-powerd.service || die
# use alternative vulkan icd option if USE=-X (bug #909181)
use X || sed -i 's/"libGLX/"libEGL/' nvidia_{layers,icd}.json || die
@@ -272,6 +274,7 @@ src_install() {
local skip_modules=(
$(usev !X "nvfbc vdpau xdriver")
$(usev !modules gsp)
+ $(usev !powerd powerd)
installer nvpd # handled separately / built from source
)
local skip_types=(
@@ -417,7 +420,7 @@ documentation that is installed alongside this README."
dobin nvidia-bug-report.sh
# MODULE:powerd extras
- if use amd64; then
+ if use powerd; then
newinitd "${FILESDIR}"/nvidia-powerd.initd nvidia-powerd #923117
systemd_dounit systemd/system/nvidia-powerd.service