summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2020-05-20 09:00:59 +0200
committerAlexys Jacob <ultrabug@gentoo.org>2020-05-20 09:00:59 +0200
commit579272022e50f45bd91ac706963a266d3a3519d3 (patch)
treeec930244cb4e0fdcf6f3c76e06937b0066a05db5 /www-servers/uwsgi/uwsgi-2.0.18.ebuild
parentvirtual/lapack: sparc stable wrt bug #698756 (diff)
downloadgentoo-579272022e50f45bd91ac706963a266d3a3519d3.tar.gz
gentoo-579272022e50f45bd91ac706963a266d3a3519d3.tar.bz2
gentoo-579272022e50f45bd91ac706963a266d3a3519d3.zip
www-servers/uwsgi: invalid IUSE semantics fixes #695146
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
Diffstat (limited to 'www-servers/uwsgi/uwsgi-2.0.18.ebuild')
-rw-r--r--www-servers/uwsgi/uwsgi-2.0.18.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/www-servers/uwsgi/uwsgi-2.0.18.ebuild b/www-servers/uwsgi/uwsgi-2.0.18.ebuild
index 53316bf30aa2..caaa3860314d 100644
--- a/www-servers/uwsgi/uwsgi-2.0.18.ebuild
+++ b/www-servers/uwsgi/uwsgi-2.0.18.ebuild
@@ -42,7 +42,7 @@ UWSGI_PLUGINS_OPT=( alarm_{curl,xmpp} clock_{monotonic,realtime} curl_cron
systemd_logger transformation_toupper tuntap webdav xattr xslt zabbix )
LANG_SUPPORT_SIMPLE=( cgi mono perl ) # plugins which can be built in the main build process
-LANG_SUPPORT_EXTENDED=( go lua php python python_asyncio python_gevent ruby )
+LANG_SUPPORT_EXTENDED=( go lua php python python-asyncio python-gevent ruby )
# plugins to be ignored (for now):
# cheaper_backlog2: example plugin
@@ -68,8 +68,8 @@ REQUIRED_USE="|| ( ${LANG_SUPPORT_SIMPLE[@]} ${LANG_SUPPORT_EXTENDED[@]} )
uwsgi_plugins_forkptyrouter? ( uwsgi_plugins_corerouter )
uwsgi_plugins_router_xmldir? ( xml !expat )
python? ( ${PYTHON_REQUIRED_USE} )
- python_asyncio? ( || ( $(python_gen_useflags -3) ) )
- python_gevent? ( python )
+ python-asyncio? ( || ( $(python_gen_useflags -3) ) )
+ python-gevent? ( python )
expat? ( xml )"
# util-linux is required for libuuid when requesting zeromq support
@@ -121,8 +121,8 @@ CDEPEND="
php_targets_php7-4? ( dev-lang/php:7.4[embed] )
)
python? ( ${PYTHON_DEPS} )
- python_asyncio? ( virtual/python-greenlet[${PYTHON_USEDEP}] )
- python_gevent? ( >=dev-python/gevent-1.3.5[${PYTHON_USEDEP}] )
+ python-asyncio? ( virtual/python-greenlet[${PYTHON_USEDEP}] )
+ python-gevent? ( >=dev-python/gevent-1.3.5[${PYTHON_USEDEP}] )
ruby? ( $(ruby_implementations_depend) )"
DEPEND="${CDEPEND}
virtual/pkgconfig"
@@ -245,17 +245,17 @@ python_compile_plugins() {
${PYTHON} uwsgiconfig.py --plugin plugins/python gentoo ${EPYV} || die "building plugin for ${EPYTHON} failed"
- if use python_asyncio ; then
+ if use python-asyncio ; then
if [[ "${PYV}" != "27" ]] ; then
${PYTHON} uwsgiconfig.py --plugin plugins/asyncio gentoo asyncio${PYV} || die "building plugin for asyncio-support in ${EPYTHON} failed"
fi
fi
- if use python_gevent ; then
+ if use python-gevent ; then
${PYTHON} uwsgiconfig.py --plugin plugins/gevent gentoo gevent${PYV} || die "building plugin for gevent-support in ${EPYTHON} failed"
fi
- if use python_gevent || use python_asyncio; then
+ if use python-gevent || use python-asyncio; then
${PYTHON} uwsgiconfig.py --plugin plugins/greenlet gentoo greenlet${PYV} || die "building plugin for greenlet-support in ${EPYTHON} failed"
fi
}
@@ -353,14 +353,14 @@ pkg_postinst() {
elog " "
elog " '--plugins ${EPYV}' for ${EPYTHON}"
- if use python_asyncio ; then
+ if use python-asyncio ; then
if [[ ${EPYV} == python34 ]] ; then
elog " '--plugins ${EPYV},asyncio${PYV}' for asyncio support in ${EPYTHON}"
else
elog " (asyncio is only supported in python3.4)"
fi
fi
- if use python_gevent ; then
+ if use python-gevent ; then
elog " '--plugins ${EPYV},gevent${PYV}' for gevent support in ${EPYTHON}"
fi
}