summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Janda <felix.janda@posteo.de>2025-01-22 00:21:11 -0500
committerSam James <sam@gentoo.org>2025-01-22 23:43:53 +0000
commitd0eb14e30572b2f1a60d7c40960eb962d6c4460f (patch)
tree4f26d27dfc732037c5429ac07b384e4f0da59624 /www-client
parentdev-lang/ada-bootstrap: fix RDEPEND (diff)
downloadgentoo-d0eb14e30572b2f1a60d7c40960eb962d6c4460f.tar.gz
gentoo-d0eb14e30572b2f1a60d7c40960eb962d6c4460f.tar.bz2
gentoo-d0eb14e30572b2f1a60d7c40960eb962d6c4460f.zip
www-client/elinks: bump to 0.18.0
Signed-off-by: Felix Janda <felix.janda@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/40252 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/elinks/Manifest1
-rw-r--r--www-client/elinks/elinks-0.18.0.ebuild211
-rw-r--r--www-client/elinks/elinks-9999.ebuild13
-rw-r--r--www-client/elinks/files/elinks-0.18.0-sftp.patch22
-rw-r--r--www-client/elinks/metadata.xml1
5 files changed, 244 insertions, 4 deletions
diff --git a/www-client/elinks/Manifest b/www-client/elinks/Manifest
index 5d822b1d34f3..8069f1174409 100644
--- a/www-client/elinks/Manifest
+++ b/www-client/elinks/Manifest
@@ -1,2 +1,3 @@
DIST elinks-0.16.1.1.tar.xz 2037292 BLAKE2B 05578eaa7a88f0abe4472b876a1f72645d32119ce807a61962f8d24a5b444240d3b94189bf25142c0e51e2d404d5992ace07ecc23ef1316d5f3942736b265267 SHA512 49e03ff4766e29b6fd4324d226e415ca1329a84d4a44fac40ecd72186dd104de88c3e541810a008dc6f1d1ed889a45edbef159cbc6ac3860756ca21261ffec8a
DIST elinks-0.17.1.1.tar.xz 2001036 BLAKE2B 2158e7630e64977b5250d544159bff0b90953ef7d51870d5e96ce8e36858596e6341bf774ad1717ed4808859d4be316fe75587552e61a8bbfcb00a0366a85e81 SHA512 7ad78f7d6a43341ae252c29f0c338e466cbedf8b40aefa9fa1939dbc62a9c9307b0a423b17181fce3bce1364fe6b6bdb80509ed90719965de174c9258b90902f
+DIST elinks-0.18.0.tar.xz 2078656 BLAKE2B 84ad13a1f374d85bb74d57fe905df4f2f1d062acb89a43197e0f0767cce3779749f4cee7ad15655fe35bc6545799b5f8264498f05a47eca6cb571541e3bcef1c SHA512 e0ff737e06d4b591d362257b9a375b938f9d6222cf6ee4df2065c7b47f883a5eacf76dabae8fc7c0b32cf9b7df56267752217d6999b0ae24c2482763b5b0ccb9
diff --git a/www-client/elinks/elinks-0.18.0.ebuild b/www-client/elinks/elinks-0.18.0.ebuild
new file mode 100644
index 000000000000..5f0b41536b9e
--- /dev/null
+++ b/www-client/elinks/elinks-0.18.0.ebuild
@@ -0,0 +1,211 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GUILE_REQ_USE="deprecated"
+GUILE_COMPAT=( 2-2 3-0 )
+PYTHON_COMPAT=( python3_{10..13} )
+LUA_COMPAT=( lua5-{1,2,3,4} luajit )
+
+inherit flag-o-matic guile-single meson lua-single python-single-r1
+
+DESCRIPTION="Advanced and well-established text-mode web browser"
+HOMEPAGE="http://elinks.or.cz/"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/rkd77/felinks"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/rkd77/elinks/releases/download/v${PV}/${P}.tar.xz"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="bittorrent brotli bzip2 curl debug finger ftp gemini gopher gpm gnutls guile idn"
+IUSE+=" javascript libcss lua lzma +mouse nls nntp perl python samba sftp ssl test tre unicode X xml zlib zstd"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ guile? ( ${GUILE_REQUIRED_USE} )
+ javascript? ( curl libcss )
+ lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ sftp? ( curl )
+"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.2:=[unicode(+)]
+ brotli? ( app-arch/brotli:= )
+ bzip2? ( >=app-arch/bzip2-1.0.2 )
+ curl? ( net-misc/curl[ssl] )
+ gpm? (
+ >=sys-libs/gpm-1.20.0-r5
+ )
+ guile? ( ${GUILE_DEPS} )
+ idn? ( net-dns/libidn2:= )
+ javascript? (
+ dev-cpp/libxmlpp:5.0
+ dev-lang/mujs:=
+ )
+ libcss? (
+ >=dev-libs/libcss-0.9.2
+ >=net-libs/libdom-0.4.2
+ )
+ lua? ( ${LUA_DEPS} )
+ lzma? ( app-arch/xz-utils )
+ perl? ( dev-lang/perl:= )
+ python? ( ${PYTHON_DEPS} )
+ samba? ( net-fs/samba )
+ ssl? (
+ !gnutls? ( dev-libs/openssl:= )
+ gnutls? ( net-libs/gnutls:= )
+ )
+ tre? ( dev-libs/tre )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXt
+ )
+ xml? ( >=dev-libs/expat-1.95.4 )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ zstd? ( app-arch/zstd:= )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? (
+ net-dns/libidn
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-sftp.patch
+)
+
+pkg_setup() {
+ use guile && guile-single_pkg_setup
+ use lua && lua-single_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ use guile && guile_bump_sources
+ python_fix_shebang .
+}
+
+src_configure() {
+ # This file is severely broken w.r.t. strict-aliasing and upstream acknowledges it:
+ # https://github.com/rkd77/elinks/blob/d05ce90b35d82109aab320b490e3ca54aa6df057/src/util/lists.h#L14
+ # https://github.com/rkd77/elinks/blob/d05ce90b35d82109aab320b490e3ca54aa6df057/src/meson.build#L44
+ #
+ # Although they force fno-strict-aliasing, they do so inconsistently and not for the testsuite (!!!).
+ # Just add it again.
+ #
+ # DO not trust the LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}"/usr/share/doc/${PF}
+ -Dhtmldoc=false
+ -Dpdfdoc=false
+ -Dapidoc=false
+ -D88-colors=true
+ -D256-colors=true
+ -Dbacktrace=$(usex elibc_musl false true)
+ $(meson_use bittorrent)
+ $(meson_use brotli)
+ $(meson_use bzip2 bzlib)
+ $(meson_use curl libcurl)
+ $(usex debug '-Ddebug=true' '-Dfastmem=true')
+ $(meson_use finger)
+ $(meson_use ftp)
+ -Dfsp=false
+ $(meson_use gemini)
+ $(meson_use nls gettext)
+ $(meson_use gopher)
+ $(meson_use gpm)
+ $(meson_use guile)
+ -Dgssapi=false
+ -Dhtml-highlight=true
+ $(meson_use idn)
+ $(meson_use javascript mujs)
+ -Dipv6=true
+ -Dleds=true
+ $(meson_use libcss)
+ -Dlibev=false
+ -Dlibevent=false
+ -Dluapkg=$(usex lua ${ELUA:-0} '')
+ $(meson_use lzma)
+ $(meson_use mouse)
+ $(meson_use nls)
+ $(meson_use nntp)
+ $(meson_use perl)
+ $(meson_use python)
+ -Dquickjs=false
+ -Druby=false
+ $(meson_use samba smb)
+ $(meson_use sftp)
+ -Dsm-scripting=false
+ -Dspidermonkey=false
+ -Dterminfo=true
+ $(meson_use test)
+ $(meson_use tre)
+ -Dtrue-color=true
+ $(meson_use xml xbel)
+ $(meson_use X x)
+ $(meson_use zlib)
+ $(meson_use zstd)
+ )
+
+ if use ssl ; then
+ if use gnutls ; then
+ emesonargs+=( -Dgnutls=true )
+ else
+ emesonargs+=( -Dopenssl=true)
+ fi
+ else
+ emesonargs+=( -Dgnutls=false -Dopenssl=false )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ insinto /etc/elinks
+ newins contrib/keybind-full.conf keybind-full.sample
+ newins contrib/keybind.conf keybind.conf.sample
+
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README.md SITES THANKS TODO doc/*.*
+ docinto contrib ; dodoc contrib/{README,colws.diff,elinks[-.]vim*}
+ docinto contrib/lua ; dodoc contrib/lua/{*.lua,elinks-remote}
+ docinto contrib/conv ; dodoc contrib/conv/*.*
+ docinto contrib/guile ; dodoc contrib/guile/*.scm
+
+ # elinks uses an internal copy of gettext which ships files that may
+ # collide with the system's gettext (https://bugs.gentoo.org/635090)
+ rm -f "${ED}"/usr/{share/locale/locale,lib/charset}.alias || die
+
+ use guile && guile_unstrip_ccache
+}
+
+pkg_postinst() {
+ elog "If upgrading from a version prior to 0.17.0, you will need to move"
+ elog "your configuration from ~/.elinks to \${XDG_CONFIG_HOME}/elinks"
+ elog
+ elog "You may want to convert your html.cfg and links.cfg of"
+ elog "Links or older ELinks versions to the new ELinks elinks.conf"
+ elog "using ${EROOT}/usr/share/doc/${PF}/contrib/conv/conf-links2elinks.pl"
+ elog
+ elog "Please have a look at ${EROOT}/etc/elinks/keybind-full.sample and"
+ elog "${EROOT}/etc/elinks/keybind.conf.sample for some bindings examples."
+ elog
+ elog "You will have to set your TERM variable to 'xterm-256color'"
+ elog "to be able to use 256 colors in elinks."
+}
diff --git a/www-client/elinks/elinks-9999.ebuild b/www-client/elinks/elinks-9999.ebuild
index daa906d436ce..780dfce3fd3a 100644
--- a/www-client/elinks/elinks-9999.ebuild
+++ b/www-client/elinks/elinks-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -24,20 +24,22 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="bittorrent brotli bzip2 debug finger ftp gemini gopher gpm gnutls guile idn"
-IUSE+=" javascript libcss lua lzma +mouse nls nntp perl python samba ssl test tre unicode X xml zlib zstd"
+IUSE="bittorrent brotli bzip2 curl debug finger ftp gemini gopher gpm gnutls guile idn"
+IUSE+=" javascript libcss lua lzma +mouse nls nntp perl python samba sftp ssl test tre unicode X xml zlib zstd"
RESTRICT="!test? ( test )"
REQUIRED_USE="
guile? ( ${GUILE_REQUIRED_USE} )
- javascript? ( libcss )
+ javascript? ( curl libcss )
lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )
+ sftp? ( curl )
"
RDEPEND="
>=sys-libs/ncurses-5.2:=[unicode(+)]
brotli? ( app-arch/brotli:= )
bzip2? ( >=app-arch/bzip2-1.0.2 )
+ curl? ( net-misc/curl[ssl] )
gpm? (
>=sys-libs/gpm-1.20.0-r5
)
@@ -110,9 +112,11 @@ src_configure() {
-Dapidoc=false
-D88-colors=true
-D256-colors=true
+ -Dbacktrace=$(usex elibc_musl false true)
$(meson_use bittorrent)
$(meson_use brotli)
$(meson_use bzip2 bzlib)
+ $(meson_use curl libcurl)
$(usex debug '-Ddebug=true' '-Dfastmem=true')
$(meson_use finger)
$(meson_use ftp)
@@ -141,6 +145,7 @@ src_configure() {
-Dquickjs=false
-Druby=false
$(meson_use samba smb)
+ $(meson_use sftp)
-Dsm-scripting=false
-Dspidermonkey=false
-Dterminfo=true
diff --git a/www-client/elinks/files/elinks-0.18.0-sftp.patch b/www-client/elinks/files/elinks-0.18.0-sftp.patch
new file mode 100644
index 000000000000..d0e024b4a031
--- /dev/null
+++ b/www-client/elinks/files/elinks-0.18.0-sftp.patch
@@ -0,0 +1,22 @@
+From 22a72290ac41d27238a8861eea60b5cf3878b94b Mon Sep 17 00:00:00 2001
+From: Felix Janda <felix.janda@posteo.de>
+Date: Sat, 18 Jan 2025 15:50:32 -0500
+Subject: [PATCH] [sftp] add declaration of ftp_curl_handle_error
+
+fixes compilation error when sftp is enabled but ftp is disabled
+---
+ src/protocol/curl/sftp.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/protocol/curl/sftp.h b/src/protocol/curl/sftp.h
+index 2ec5a0542..5b42bccaa 100644
+--- a/src/protocol/curl/sftp.h
++++ b/src/protocol/curl/sftp.h
+@@ -12,6 +12,7 @@ extern struct module sftp_protocol_module;
+
+ #if defined(CONFIG_SFTP) && defined(CONFIG_LIBCURL)
+ extern protocol_handler_T sftp_protocol_handler;
++void ftp_curl_handle_error(struct connection *conn, CURLcode res);
+ #else
+ #define sftp_protocol_handler NULL
+ #endif
diff --git a/www-client/elinks/metadata.xml b/www-client/elinks/metadata.xml
index 2c7701cba575..6c05bbc00043 100644
--- a/www-client/elinks/metadata.xml
+++ b/www-client/elinks/metadata.xml
@@ -16,6 +16,7 @@
<flag name="gopher">Enable support for the gopher protocol</flag>
<flag name="libcss">Enable support for cascading style sheets via <pkg>dev-libs/libcss</pkg></flag>
<flag name="mouse">Make elinks to grab all mouse events</flag>
+ <flag name="sftp">Add support for sftp (requires <pkg>net-misc/curl</pkg>).</flag>
<flag name="tre">Enable support for regex searches via <pkg>dev-libs/tre</pkg></flag>
<flag name="xml">Enable support for bookmarks via <pkg>dev-libs/expat</pkg></flag>
</use>