summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2020-12-17 17:36:17 +0100
committerStephan Hartmann <sultan@gentoo.org>2020-12-17 18:26:44 +0100
commit7bff7b3270fda37788798f67d233a58d2d716417 (patch)
tree9bb3ed2eb92d2bddd4f348b04ae877ac547bc3e9 /www-client
parentmedia-tv/mythtv: Support Python 3.8 (diff)
downloadgentoo-7bff7b3270fda37788798f67d233a58d2d716417.tar.gz
gentoo-7bff7b3270fda37788798f67d233a58d2d716417.tar.bz2
gentoo-7bff7b3270fda37788798f67d233a58d2d716417.zip
www-client/opera: fix widevine installation
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/opera/opera-73.0.3856.284-r1.ebuild (renamed from www-client/opera/opera-73.0.3856.284.ebuild)13
1 files changed, 7 insertions, 6 deletions
diff --git a/www-client/opera/opera-73.0.3856.284.ebuild b/www-client/opera/opera-73.0.3856.284-r1.ebuild
index a604819847f8..8dd3db974120 100644
--- a/www-client/opera/opera-73.0.3856.284.ebuild
+++ b/www-client/opera/opera-73.0.3856.284-r1.ebuild
@@ -93,12 +93,12 @@ src_install() {
# move to /opt, bug #573052
mkdir -p "${OPERA_HOME%${PN}}"
mv "usr/lib/x86_64-linux-gnu/${PN}" "${OPERA_HOME%${PN}}" || die
- rm -rf "usr/lib" || die
+ rm -r "usr/lib" || die
# disable auto update
rm "${OPERA_HOME}/${PN%-*}_autoupdate"{,.licenses,.version} || die
- rm -rf "usr/share/lintian" || die
+ rm -r "usr/share/lintian" || die
# fix docs
mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
@@ -115,19 +115,20 @@ src_install() {
popd > /dev/null || die
# setup opera symlink
- rm -f "usr/bin/${PN}" || die
+ rm "usr/bin/${PN}" || die
dosym "../../${OPERA_HOME}/${PN}" "/usr/bin/${PN}"
# install proprietary codecs
- rm -f "resources/ffmpeg_preload_config.json" || die
+ rm "${OPERA_HOME}/resources/ffmpeg_preload_config.json" || die
if use proprietary-codecs; then
mv lib_extra "${OPERA_HOME}"
fi
# symlink widevine
- rm -f "resources/widevine_config.json" || die
+ rm "${OPERA_HOME}/resources/widevine_config.json" || die
if use widevine; then
- dosym "../../usr/$(get_libdir)/chromium-browser/WidevineCdm" "${OPERA_HOME}/WidevineCdm"
+ echo "[\"${EPREFIX}/usr/$(get_libdir)/chromium-browser/WidevineCdm\"]" > \
+ "${OPERA_HOME}/resources/widevine_config.json" || die
fi
# pax mark opera, bug #562038