summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-08-12 09:27:15 +1000
committerMatt Jolly <kangie@gentoo.org>2024-08-12 10:24:04 +1000
commit7a453f36288fe99fb5abe2aa77ac603e5b17824e (patch)
tree921a4bb192c1a87a2e6f3f9d67d80037b9148757 /www-client
parentwww-plugins/chrome-binary-plugins: automated update (129.0.6643.2_alpha) (diff)
downloadgentoo-7a453f36288fe99fb5abe2aa77ac603e5b17824e.tar.gz
gentoo-7a453f36288fe99fb5abe2aa77ac603e5b17824e.tar.bz2
gentoo-7a453f36288fe99fb5abe2aa77ac603e5b17824e.zip
www-client/microsoft-edge: automated bump (127.0.2651.98)
Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/microsoft-edge/Manifest1
-rw-r--r--www-client/microsoft-edge/microsoft-edge-127.0.2651.98.ebuild126
2 files changed, 127 insertions, 0 deletions
diff --git a/www-client/microsoft-edge/Manifest b/www-client/microsoft-edge/Manifest
index 5b20faf9fc31..9c379786da96 100644
--- a/www-client/microsoft-edge/Manifest
+++ b/www-client/microsoft-edge/Manifest
@@ -1 +1,2 @@
DIST microsoft-edge-stable_127.0.2651.86-1_amd64.deb 167183974 BLAKE2B 5251327715e334b12fee5e7e32931ce531bac2508681ecb86dfec25d33c3113df80571bea671f2949c5329b8f1d49c30c57b3ab8c3406fb159e32fd130ad69b0 SHA512 b96a03ad1a8eaee44b58a79a9db75b51109b5e77b484595fca93b15102abbfa0bf5f6cdbc891504ef5a4eb2ef5cb415164bdca125260b68b8e616f10fa11de9d
+DIST microsoft-edge-stable_127.0.2651.98-1_amd64.deb 167212578 BLAKE2B 84fde8de1cbd92c0fabb71fbeceab65bfeebd136f846bc076e477eb4b81b9deb60d6555ed79f996fd2bddaf70024a9523dd5afebf27e079b9763c866633f1138 SHA512 c6ae01602250bbcacc224c886de43a1221ced78a8bb78ae33cbe6758989dcf73e9df89cd5113194ce303c8a1251e97492cfdd752207a4c83efddf355f8a38e1e
diff --git a/www-client/microsoft-edge/microsoft-edge-127.0.2651.98.ebuild b/www-client/microsoft-edge/microsoft-edge-127.0.2651.98.ebuild
new file mode 100644
index 000000000000..0ff710cc5ddc
--- /dev/null
+++ b/www-client/microsoft-edge/microsoft-edge-127.0.2651.98.ebuild
@@ -0,0 +1,126 @@
+# Copyright 2011-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit chromium-2 desktop pax-utils unpacker xdg
+
+DESCRIPTION="The web browser from Microsoft"
+HOMEPAGE="https://www.microsoft.com/edge"
+
+if [[ ${PN} == microsoft-edge ]]; then
+ MY_PN=${PN}-stable
+else
+ MY_PN=${PN}
+fi
+
+MY_P="${MY_PN}_${PV}-1"
+SRC_URI="https://packages.microsoft.com/repos/edge/pool/main/m/${MY_PN}/${MY_P}_amd64.deb"
+S=${WORKDIR}
+
+LICENSE="microsoft-edge"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+IUSE="+mip qt5 qt6"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/liberation-fonts
+ media-libs/alsa-lib
+ media-libs/mesa[gbm(+)]
+ net-misc/curl[ssl]
+ net-print/cups
+ sys-apps/dbus
+ sys-apps/util-linux
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3[X]
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/libxshmfence
+ x11-libs/pango
+ x11-misc/xdg-utils
+ mip? ( app-crypt/libsecret )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[X]
+ dev-qt/qtwidgets:5
+ )
+ qt6? ( dev-qt/qtbase:6[gui,widgets] )
+"
+
+QA_PREBUILT="*"
+QA_DESKTOP_FILE="usr/share/applications/microsoft-edge.*\\.desktop"
+EDGE_HOME="opt/microsoft/msedge${PN#microsoft-edge}"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your tree before reporting a bug for microsoft-edge fetch failures."
+}
+
+pkg_pretend() {
+ # Protect against people using autounmask overzealously
+ use amd64 || die "microsoft-edge only works on amd64"
+}
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ dodir /
+ cd "${ED}" || die
+ unpacker
+
+ rm -f _gpgorigin || die
+
+ rm -r etc usr/share/menu || die
+ mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
+
+ gzip -d usr/share/doc/${PF}/changelog.gz || die
+ gzip -d usr/share/man/man1/${MY_PN}.1.gz || die
+ if [[ -L usr/share/man/man1/${PN}.1.gz ]]; then
+ rm usr/share/man/man1/${PN}.1.gz || die
+ dosym ${MY_PN}.1 usr/share/man/man1/${PN}.1
+ fi
+
+ local suffix=
+ [[ ${PN} == microsoft-edge-beta ]] && suffix=_beta
+ [[ ${PN} == microsoft-edge-dev ]] && suffix=_dev
+
+ local size
+ for size in 16 24 32 48 64 128 256 ; do
+ newicon -s ${size} "${EDGE_HOME}/product_logo_${size}${suffix}.png" ${PN}.png
+ done
+
+ if ! use mip; then
+ rm "${EDGE_HOME}"/libmip_{core,protection_sdk}.so || die
+ fi
+
+ if ! use qt5; then
+ rm "${EDGE_HOME}/libqt5_shim.so" || die
+ fi
+ if ! use qt6; then
+ rm "${EDGE_HOME}/libqt6_shim.so" || die
+ fi
+
+ pax-mark m "${EDGE_HOME}/msedge"
+}