summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-client/rekonq
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-client/rekonq')
-rw-r--r--www-client/rekonq/Manifest1
-rw-r--r--www-client/rekonq/metadata.xml12
-rw-r--r--www-client/rekonq/rekonq-2.4.2-r1.ebuild50
3 files changed, 63 insertions, 0 deletions
diff --git a/www-client/rekonq/Manifest b/www-client/rekonq/Manifest
new file mode 100644
index 000000000000..b662e73c7840
--- /dev/null
+++ b/www-client/rekonq/Manifest
@@ -0,0 +1 @@
+DIST rekonq-2.4.2.tar.xz 5161348 SHA256 e9805b32f592ca5809bd1632c624c57fc0109ce98b73a8b8e3ebd04e9c875126 SHA512 55594dac99b06db7986198f1b6e8efdb0770e2219a33d34db7919d4d0d741ef026b0e12d284ae9b2e1a9b6e40efcdf4f0870e9b0819bff14f45162c5b464ba78 WHIRLPOOL 9e555f5ad935bd2e73ef62e6ccc8f634d3dedf219a5f1ef7a2c356123b0d56d47e2a177cabfb0803ca7f48ebef60a72e34801aa6c9904891630f7b47af08b2ba
diff --git a/www-client/rekonq/metadata.xml b/www-client/rekonq/metadata.xml
new file mode 100644
index 000000000000..8aa324273fae
--- /dev/null
+++ b/www-client/rekonq/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="nepomuk">Enable Nepomuk based semantic desktop support (deprecated)</flag>
+ <flag name="opera">Support for Opera sync handler</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">rekonq</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-client/rekonq/rekonq-2.4.2-r1.ebuild b/www-client/rekonq/rekonq-2.4.2-r1.ebuild
new file mode 100644
index 000000000000..dc3369cdaff6
--- /dev/null
+++ b/www-client/rekonq/rekonq-2.4.2-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WEBKIT_REQUIRED="always"
+KDE_LINGUAS="cs da de el es et eu fi fr gl hu ia it km lt mr nb nl pl pt pt_BR
+sk sl sr sr@ijekavian sr@ijekavianlatin sr@latin sv tr uk zh_CN zh_TW"
+KDE_HANDBOOK="optional"
+KDE_MINIMAL="4.13.1"
+inherit kde4-base
+
+DESCRIPTION="A browser based on qtwebkit"
+HOMEPAGE="http://rekonq.kde.org/"
+[[ ${PV} != *9999* ]] && SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="4"
+KEYWORDS="amd64 x86"
+IUSE="debug kde nepomuk opera"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'nepomuk?')
+ kde? ( $(add_kdebase_dep kactivities) )
+ nepomuk? (
+ $(add_kdebase_dep nepomuk-core)
+ dev-libs/soprano
+ )
+ opera? (
+ app-crypt/qca:2[qt4(+)]
+ dev-libs/qoauth
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ $(add_kdeapps_dep kdebase-kioslaves)
+ $(add_kdeapps_dep keditbookmarks)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with kde KActivities)
+ $(cmake-utils_use_with opera QCA2)
+ $(cmake-utils_use_with opera QtOAuth)
+ $(cmake-utils_use_find_package nepomuk NepomukCore)
+ )
+
+ kde4-base_src_configure
+}