summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-07-12 22:05:34 +0100
committerJames Le Cuirot <chewi@gentoo.org>2023-07-12 22:05:34 +0100
commit2aa4540fa64fc1e27a5dedc7e23c376183742308 (patch)
tree8c650f051429f88adf81d8b04ab1c435d0bce1ea /www-apps
parentgui-wm/gamescope: Bump to 3.12.0_beta10. drop old 3.12.0_beta7 (diff)
downloadgentoo-2aa4540fa64fc1e27a5dedc7e23c376183742308.tar.gz
gentoo-2aa4540fa64fc1e27a5dedc7e23c376183742308.tar.bz2
gentoo-2aa4540fa64fc1e27a5dedc7e23c376183742308.zip
www-apps/xpra-html5: Version bump to 8.1
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/xpra-html5/Manifest1
-rw-r--r--www-apps/xpra-html5/xpra-html5-8.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/www-apps/xpra-html5/Manifest b/www-apps/xpra-html5/Manifest
index 6c4732559314..6143090a22c4 100644
--- a/www-apps/xpra-html5/Manifest
+++ b/www-apps/xpra-html5/Manifest
@@ -1 +1,2 @@
DIST xpra-html5-6.1.tar.gz 1416380 BLAKE2B ba0e2bdcae91b30a1f46655dc505f5338cd8c516414f55871c6bc01b6bdcd81d351d66c575c6a7a219cb0c29e7da17e8db558b928dc89067b5ad3289520005f2 SHA512 3539c235f38a66f0a8eaea679df4b4bb4a1ef778ab31baf705acc29b0d4b3998ae84081eeac085db973d170afaa1ee0f167124efc3e48266145fdbef255a6bf5
+DIST xpra-html5-8.1.tar.gz 1328112 BLAKE2B c9ada4a5131273e29aa02cbee740bfaa7bcf50751231cd0fd04e9ccbd29a4cea31a0617a51019120ccf68fc9b8060c2f837f000c3ca67d2d049e9b1d27a622e0 SHA512 c02aa50e65414b06fe978113005fd13f631d73bde602a4d5c3c4d7281dfe23330cee01bb5c0701652fe1c91d91350dd9bc9b4f5144f6940ab4a83cf6743be1dd
diff --git a/www-apps/xpra-html5/xpra-html5-8.1.ebuild b/www-apps/xpra-html5/xpra-html5-8.1.ebuild
new file mode 100644
index 000000000000..e5118ee749bc
--- /dev/null
+++ b/www-apps/xpra-html5/xpra-html5-8.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+inherit python-any-r1
+
+DESCRIPTION="HTML5 client to connect to any xpra server"
+HOMEPAGE="https://xpra.org/"
+SRC_URI="https://github.com/Xpra-org/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="brotli +gzip minify"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ brotli? ( app-arch/brotli )
+ minify? ( dev-util/uglifyjs )
+"
+
+src_configure() {
+ cat <<EOF > vcs-info || die
+BRANCH=gentoo
+REVISION=${PR#r}
+LOCAL_MODIFICATIONS=0
+EOF
+}
+
+src_install() {
+ "${PYTHON}" <<EOF || die
+import setup
+setup.set_version("${PV}")
+setup.install_html5(
+ root="${D}",
+ install_dir="${EPREFIX}/usr/share/xpra/www/",
+ config_dir="${EPREFIX}/etc/xpra/html5-client",
+ minifier="$(usex minify uglifyjs copy)",
+ gzip=$(usex gzip True False),
+ brotli=$(usex brotli True False),
+)
+EOF
+}