summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-12-15 10:21:52 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-12-15 10:21:52 +0100
commit4e1de51857ca726ae9871662aa6b9c62476a415a (patch)
treee34d1036d78fd1c4521228dabd306282bac1d8b0 /www-apps/piwigo
parentwww-apps/element: add 1.11.51 (diff)
downloadgentoo-4e1de51857ca726ae9871662aa6b9c62476a415a.tar.gz
gentoo-4e1de51857ca726ae9871662aa6b9c62476a415a.tar.bz2
gentoo-4e1de51857ca726ae9871662aa6b9c62476a415a.zip
www-apps/piwigo: add 14.0.0
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'www-apps/piwigo')
-rw-r--r--www-apps/piwigo/Manifest1
-rw-r--r--www-apps/piwigo/piwigo-14.0.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/www-apps/piwigo/Manifest b/www-apps/piwigo/Manifest
index 441a50855467..f91052045d67 100644
--- a/www-apps/piwigo/Manifest
+++ b/www-apps/piwigo/Manifest
@@ -1 +1,2 @@
DIST piwigo-13.8.0.zip 18345886 BLAKE2B d2cb7c334a651c302b9a94bb09c5fcb0f658cc82ce45aebdb782da26f137348f77d93a9915f56584739e4f493f0cdffbaf353997842424b1aab20488554dfa6d SHA512 52c29ca0899f5df34667c0148d57c9e71f75056e94caffafdb98d0181f2198123d123121bd2ada3405293dea71cb95371f4387ee3dbcfe942d9530b21d76ce34
+DIST piwigo-14.0.0.zip 18442805 BLAKE2B 22c714f68c6f68d7fe9a1bd8303a7ef63ac30dd6862d3dfd32f1bd3754a1805b8cfd321e3b734fe6eba3485374452befa7f2e0bfe0795a34e6ea25d1d1bada5a SHA512 cb679faeec7b188ece561ea5f1bf3fbf4acd513205f0492c5932921aae2676489089241f57fad3b1623e019772e39821121765bc0648d95da8f06d5a644e5a96
diff --git a/www-apps/piwigo/piwigo-14.0.0.ebuild b/www-apps/piwigo/piwigo-14.0.0.ebuild
new file mode 100644
index 000000000000..825f7096685f
--- /dev/null
+++ b/www-apps/piwigo/piwigo-14.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit webapp
+
+DESCRIPTION="a photo gallery software for the web"
+HOMEPAGE="http://piwigo.org/"
+SRC_URI="http://piwigo.org/download/dlcounter.php?code=${PV} -> ${P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+exif +gd imagemagick"
+
+DEPEND=""
+RDEPEND="
+ imagemagick? ( virtual/imagemagick-tools )
+ dev-lang/php[ctype,exif?,gd?,filter,iconv,json(+),mysqli]
+ >=virtual/mysql-5.0
+ virtual/httpd-php"
+BDEPEND="app-arch/unzip"
+
+REQUIRED_USE="|| ( gd imagemagick )"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # Local configuration, and parts that can be updated
+ webapp_serverowned "${MY_HTDOCSDIR}"/_data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/galleries
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/language
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/local
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/plugins
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/template-extension
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/themes
+ webapp_serverowned "${MY_HTDOCSDIR}"/upload
+
+ webapp_src_install
+}