summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-07-09 11:20:38 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2023-07-09 11:20:51 +0200
commit4302f0aa0d918450c3d0107738851fd53f67bba8 (patch)
tree60f42ee99e8f5c1c7161606e7d6b8d0c0e5ded45 /www-apps/piwigo
parentmedia-video/devedeng: update upstream metadata (diff)
downloadgentoo-4302f0aa0d918450c3d0107738851fd53f67bba8.tar.gz
gentoo-4302f0aa0d918450c3d0107738851fd53f67bba8.tar.bz2
gentoo-4302f0aa0d918450c3d0107738851fd53f67bba8.zip
www-apps/piwigo: add 13.8.0
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'www-apps/piwigo')
-rw-r--r--www-apps/piwigo/Manifest1
-rw-r--r--www-apps/piwigo/piwigo-13.8.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/www-apps/piwigo/Manifest b/www-apps/piwigo/Manifest
index c21532689bd1..c476c768ce69 100644
--- a/www-apps/piwigo/Manifest
+++ b/www-apps/piwigo/Manifest
@@ -1 +1,2 @@
DIST piwigo-13.7.0.zip 18306599 BLAKE2B 2be2dbccc3cc1ea42c3a9ff7d3578b96261230953eb8bda0b7d50e6fe559a2a72c98419e688b6f25b43d52117163c12d2ea81424a02197d64a6d9d1872618906 SHA512 8af4f2e8fce1db9c28a86202f2b7d1d7d2f4ffd802131e8db41b00b304bf487c1b161a0a6d72a61944c72cc6c391097f3fa2221c4d91dbd82bb7979defeac2be
+DIST piwigo-13.8.0.zip 18345886 BLAKE2B d2cb7c334a651c302b9a94bb09c5fcb0f658cc82ce45aebdb782da26f137348f77d93a9915f56584739e4f493f0cdffbaf353997842424b1aab20488554dfa6d SHA512 52c29ca0899f5df34667c0148d57c9e71f75056e94caffafdb98d0181f2198123d123121bd2ada3405293dea71cb95371f4387ee3dbcfe942d9530b21d76ce34
diff --git a/www-apps/piwigo/piwigo-13.8.0.ebuild b/www-apps/piwigo/piwigo-13.8.0.ebuild
new file mode 100644
index 000000000000..825f7096685f
--- /dev/null
+++ b/www-apps/piwigo/piwigo-13.8.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit webapp
+
+DESCRIPTION="a photo gallery software for the web"
+HOMEPAGE="http://piwigo.org/"
+SRC_URI="http://piwigo.org/download/dlcounter.php?code=${PV} -> ${P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+exif +gd imagemagick"
+
+DEPEND=""
+RDEPEND="
+ imagemagick? ( virtual/imagemagick-tools )
+ dev-lang/php[ctype,exif?,gd?,filter,iconv,json(+),mysqli]
+ >=virtual/mysql-5.0
+ virtual/httpd-php"
+BDEPEND="app-arch/unzip"
+
+REQUIRED_USE="|| ( gd imagemagick )"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # Local configuration, and parts that can be updated
+ webapp_serverowned "${MY_HTDOCSDIR}"/_data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/galleries
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/language
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/local
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/plugins
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/template-extension
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/themes
+ webapp_serverowned "${MY_HTDOCSDIR}"/upload
+
+ webapp_src_install
+}