summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/nikola/nikola-7.2.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/nikola/nikola-7.2.0.ebuild')
-rw-r--r--www-apps/nikola/nikola-7.2.0.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/www-apps/nikola/nikola-7.2.0.ebuild b/www-apps/nikola/nikola-7.2.0.ebuild
new file mode 100644
index 000000000000..bae5e7c07b84
--- /dev/null
+++ b/www-apps/nikola/nikola-7.2.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+DESCRIPTION="A static website and blog generator"
+HOMEPAGE="http://getnikola.com/"
+MY_PN="Nikola"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/ralsina/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${P}.tar.gz"
+ KEYWORDS="amd64"
+fi
+
+LICENSE="MIT-with-advertising Apache-2.0" # Gutenberg
+SLOT="0"
+IUSE="assets charts hyphenation ipython jinja markdown"
+RESTRICT="test" # needs freezegun, coveralls, and phpserialize
+
+DEPEND=">=dev-python/docutils-0.12[${PYTHON_USEDEP}]" # needs rst2man to build manpage
+RDEPEND="${DEPEND}
+ >=dev-python/blinker-1.3[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/doit-0.23.0[${PYTHON_USEDEP}]
+ >=dev-python/logbook-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.3.5[${PYTHON_USEDEP}]
+ >=dev-python/mako-1.0[${PYTHON_USEDEP}]
+ >=dev-python/natsort-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pygments-1.6[${PYTHON_USEDEP}]
+ >=dev-python/PyRSS2Gen-1.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.2[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-5.4.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/unidecode-0.04.16[${PYTHON_USEDEP}]
+ >=dev-python/yapsy-1.10.423[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ assets? ( >=dev-python/webassets-0.10.1[${PYTHON_USEDEP}] )
+ charts? ( >=dev-python/pygal-1.5.1[${PYTHON_USEDEP}] )
+ hyphenation? ( >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}] )
+ ipython? ( >=dev-python/ipython-1.2.1[${PYTHON_USEDEP}] )
+ jinja? ( >=dev-python/jinja-2.7.2[${PYTHON_USEDEP}] )
+ markdown? ( >=dev-python/markdown-2.4.0[${PYTHON_USEDEP}] )"
+# more options as packages will be added:
+# livereload? ( =dev-python/livereload-2.3.1[${PYTHON_USEDEP}] )
+# micawber? ( >=dev-python/micawber-0.3.0[${PYTHON_USEDEP}] )
+# typogrify? ( >=dev-python/typogrify-2.0.4[${PYTHON_USEDEP}] )
+
+src_install() {
+ distutils-r1_src_install
+
+ # hackish way to remove docs that ended up in the wrong place
+ rm -rf "${D}"/usr/share/doc/${PN}
+
+ dodoc AUTHORS.txt CHANGES.txt README.rst docs/*.txt
+ doman docs/man/*
+}