summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2024-06-16 15:31:35 +0200
committerLouis Sautier <sbraz@gentoo.org>2024-06-16 15:45:34 +0200
commit86ade633551d10c7afa7c4203cf5d2a99fb562b2 (patch)
treed111ea668c68c3658a417a17928b7d48bc937ca1 /www-apps/klaus
parentdev-java/openjdk-bin: keyword openjdk-bin-21 for riscv (diff)
downloadgentoo-86ade633551d10c7afa7c4203cf5d2a99fb562b2.tar.gz
gentoo-86ade633551d10c7afa7c4203cf5d2a99fb562b2.tar.bz2
gentoo-86ade633551d10c7afa7c4203cf5d2a99fb562b2.zip
www-apps/klaus: add 3.0.0, enable Python 3.13
httpauth >= 0.4 is now required as per setup.py. Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'www-apps/klaus')
-rw-r--r--www-apps/klaus/Manifest1
-rw-r--r--www-apps/klaus/files/klaus-3.0.0-fix-cli.py22
-rw-r--r--www-apps/klaus/klaus-3.0.0.ebuild39
3 files changed, 62 insertions, 0 deletions
diff --git a/www-apps/klaus/Manifest b/www-apps/klaus/Manifest
index f18d5856d648..c0a5d6fdfde2 100644
--- a/www-apps/klaus/Manifest
+++ b/www-apps/klaus/Manifest
@@ -1,2 +1,3 @@
DIST klaus-2.0.2.tar.gz 43030 BLAKE2B ba3a1d07d92ab02e43a31f9e720e26bafc744c2867b8bd6cf300d6e2fdcbcb560a426e8cf55bd6d8c11d23775ae5beddb8fd3ee89c3b0f21302bb463cc2571f3 SHA512 87aa4943d4e918c7ac9c269c095b8381b9e367ed68a50fb70bd75e02ec723c379d0ceaa2da9d5b81484b4c308941283dd2fb58046ba18e0950611c51b2337edd
DIST klaus-2.0.3.tar.gz 46961 BLAKE2B 29d84ccf829853f091f8bc944e4bf0ec119e1a2dcf67c7d82561a0924cc60634ec67580b6d9103fe33e7a4f40dc909d9dd04f1765441b9dbfd2638adad91df48 SHA512 81bb1ecd01555bb3e49b4fa482e8bfc679b9754047508201467640bab25e56e3f109339efa419f00b05d99d27138a16ab5fb7c3578792992e343653eb175fc1e
+DIST klaus-3.0.0.tar.gz 47126 BLAKE2B ebbd2292dda20f869d69775aa38aaf9e5238079e4ec16a85838cae823ffb7c8135bbf77c30ac2d0ae050d49b7f2ac9c1feba5585b4f62b0fa8e9db656299166c SHA512 4495e4e7e2cecffd1f768eca1e7f8811b98e88c35650f18a4c06be39244302b09955b41cb7fa89545db157b00a2cae2d9a404d6ff26cf166f133fda06ca36d08
diff --git a/www-apps/klaus/files/klaus-3.0.0-fix-cli.py b/www-apps/klaus/files/klaus-3.0.0-fix-cli.py
new file mode 100644
index 000000000000..672cfeeb198b
--- /dev/null
+++ b/www-apps/klaus/files/klaus-3.0.0-fix-cli.py
@@ -0,0 +1,22 @@
+https://github.com/jonashaag/klaus/pull/333
+
+From a7f0a5511c4ee25e82ea704b90482c24f16f5bff Mon Sep 17 00:00:00 2001
+From: Louis Sautier <sautier.louis@gmail.com>
+Date: Sun, 16 Jun 2024 15:23:35 +0200
+Subject: [PATCH] cli: fix startup with --ctags, fixes #330
+
+It had been broken by 36a6d2c617f1120.
+--- a/klaus/cli.py
++++ b/klaus/cli.py
+@@ -102,9 +102,9 @@ def main():
+ args.site_name = "%s:%d" % (args.host, args.port)
+
+ if args.ctags != "none":
+- from klaus.ctagsutils import check_have_exuberant_ctags
++ from klaus.ctagsutils import check_have_compatible_ctags
+
+- if not check_have_exuberant_ctags():
++ if not check_have_compatible_ctags():
+ print(
+ "ERROR: Exuberant ctags not installed (or 'ctags' binary isn't *Exuberant* ctags)",
+ file=sys.stderr,
diff --git a/www-apps/klaus/klaus-3.0.0.ebuild b/www-apps/klaus/klaus-3.0.0.ebuild
new file mode 100644
index 000000000000..6b91c9c1c5d4
--- /dev/null
+++ b/www-apps/klaus/klaus-3.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A simple, easy-to-set-up Git web viewer"
+HOMEPAGE="https://github.com/jonashaag/klaus/"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ctags"
+
+# Tests can only be run from a git repository so they are not included in
+# source distributions.
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/dulwich-0.19.3[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/httpauth-0.4[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ ctags? ( dev-python/python-ctags3[${PYTHON_USEDEP}] )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-cli.py"
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman ${PN}.1
+}