summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2024-07-30 16:39:27 +0000
committerJoonas Niilola <juippis@gentoo.org>2024-08-05 09:58:13 +0300
commit1281c2b755d9c2dec32c47766867de759ba9cfce (patch)
tree65e1a6277e0b45ad842ba28874d350eb245eea7f /www-apache
parentdev-db/barman: add 3.10.1 (diff)
downloadgentoo-1281c2b755d9c2dec32c47766867de759ba9cfce.tar.gz
gentoo-1281c2b755d9c2dec32c47766867de759ba9cfce.tar.bz2
gentoo-1281c2b755d9c2dec32c47766867de759ba9cfce.zip
www-apache/modsecurity-crs: add 4.5.0
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/37826 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/modsecurity-crs/Manifest1
-rw-r--r--www-apache/modsecurity-crs/modsecurity-crs-4.5.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/www-apache/modsecurity-crs/Manifest b/www-apache/modsecurity-crs/Manifest
index f5e40040a631..3a6a2e524a0b 100644
--- a/www-apache/modsecurity-crs/Manifest
+++ b/www-apache/modsecurity-crs/Manifest
@@ -1,3 +1,4 @@
DIST modsecurity-crs-3.3.5.tar.gz 299458 BLAKE2B b8617de77cf5168c7b95fab46eae45e2101b4ec7a537d8d471b9b1b27a856b1d370a9de43ee262c07dc9371b3ff79cd86b7328b171fde003da9110897206e91e SHA512 001f9afe25f479dd988aaec1a4a2c0197b2d27e00d2cd10b70892e4889b399259cd0655f42a96965ae655855abdb7f9d8295c225ae17bf1e47361b70232633e5
DIST modsecurity-crs-4.0.0.tar.gz 504720 BLAKE2B e6da0268ae9209179d1f6cefba34e097b614dd4659a4b4df2ef3e6a0b32be7be9d825beaf6d8ca1fbef0dd27217b4707090844e59eaa817111be4a6f8333e205 SHA512 c25bfd6de772815977783e78d7afd388d60bbba151762a38c7050fd5ecde6a48baa0a850028a24d42855ae4a788404ad1ee0f7a4ad2d94d53a46e261a00f7224
DIST modsecurity-crs-4.4.0.tar.gz 510998 BLAKE2B 770a392836fbe29b69d0aa0b487bd7798cc618d1a5923d169a04bcac52b3add6dee8d5777e97e9b3afb3776bc442fb004e02c0c27becb07df62f2fa289d70be9 SHA512 a196a922c5456a2f025f43f8c0b5e3905eed8b3586c54d7b7771c386e5226d8dc6fce2b0bc05d69b389b07d5935bf8abbfb0a524e8ef856a433e9e4aed4b448d
+DIST modsecurity-crs-4.5.0.tar.gz 508360 BLAKE2B 88d63ed74e0c10577fd614cd782a247b00fc2e9a18f3f8c8dcb26f848e8b2025aa699a125c682cd2d82d386202205278b570d8adc57c56ad1e8ada1c780841a7 SHA512 057ed442b435efe4f6092bc05e55a7d133e3a62b92744c2a151291e6e21722fa37857729c4434814f0996b3f814118fd64a76c8ceb7b430cbe0b8921295556df
diff --git a/www-apache/modsecurity-crs/modsecurity-crs-4.5.0.ebuild b/www-apache/modsecurity-crs/modsecurity-crs-4.5.0.ebuild
new file mode 100644
index 000000000000..1a0a134d3046
--- /dev/null
+++ b/www-apache/modsecurity-crs/modsecurity-crs-4.5.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+MY_PV=${PV/_/-}
+
+DESCRIPTION="OWASP ModSecurity Core Rule Set"
+HOMEPAGE="https://coreruleset.org/"
+SRC_URI="https://github.com/coreruleset/coreruleset/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/coreruleset-${MY_PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+apache2"
+
+RDEPEND="apache2? ( >=www-apache/mod_security-2.9.6 )"
+
+DOCS=( CHANGES.md CONTRIBUTORS.md crs-setup.conf.example KNOWN_BUGS.md README.md )
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r plugins rules
+
+ einstalldocs
+
+ if use apache2; then
+ # I don't think it's worth pulling in apache-module.eclass just for
+ # this path...
+ insinto /etc/apache2/modules.d
+ doins "${FILESDIR}/80_mod_security-crs.conf"
+ fi
+}
+
+pkg_postinst() {
+ if use apache2; then
+ einfo "The CRS configuration file has been installed to:"
+ einfo " ${ROOT}/etc/apache2/modules.d/80_mod_security-crs.conf"
+ fi
+
+ optfeature "apache-less installations, e.g. nginx" dev-libs/modsecurity
+}