summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-05-24 17:15:10 +0200
committerMichał Górny <mgorny@gentoo.org>2019-05-24 17:17:56 +0200
commit2deadbe20f31fdfd4cef79ec971d96ada19d1a41 (patch)
tree86ecd88212b08e7de71c7536be96c3da7b468fd3 /virtual/python-funcsigs/python-funcsigs-2-r1.ebuild
parentxfce-base/xfce4-meta: add 4.14_pre1 (diff)
downloadgentoo-2deadbe20f31fdfd4cef79ec971d96ada19d1a41.tar.gz
gentoo-2deadbe20f31fdfd4cef79ec971d96ada19d1a41.tar.bz2
gentoo-2deadbe20f31fdfd4cef79ec971d96ada19d1a41.zip
virtual/python-funcsigs: pypy3 is now py3.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'virtual/python-funcsigs/python-funcsigs-2-r1.ebuild')
-rw-r--r--virtual/python-funcsigs/python-funcsigs-2-r1.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/virtual/python-funcsigs/python-funcsigs-2-r1.ebuild b/virtual/python-funcsigs/python-funcsigs-2-r1.ebuild
new file mode 100644
index 000000000000..d67b420a1734
--- /dev/null
+++ b/virtual/python-funcsigs/python-funcsigs-2-r1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+
+inherit python-r1
+
+DESCRIPTION="A Virtual for Python function signatures from PEP362 (py3.6 variant)"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '>=dev-python/funcsigs-1[${PYTHON_USEDEP}]' python2_7 python3_5 pypy )"