summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-26 03:54:40 +0100
committerSam James <sam@gentoo.org>2023-09-26 03:54:40 +0100
commit07f45db4be687116b4f75edc3a3db24d99eb775e (patch)
treed59d2f163d6a2e44e291043b4e2ad8a4ed77f42d /sys-process/parallel
parentsys-process/parallel: drop 20230522, 20230622 (diff)
downloadgentoo-07f45db4be687116b4f75edc3a3db24d99eb775e.tar.gz
gentoo-07f45db4be687116b4f75edc3a3db24d99eb775e.tar.bz2
gentoo-07f45db4be687116b4f75edc3a3db24d99eb775e.zip
sys-process/parallel: add 20230922
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process/parallel')
-rw-r--r--sys-process/parallel/Manifest2
-rw-r--r--sys-process/parallel/parallel-20230922.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-process/parallel/Manifest b/sys-process/parallel/Manifest
index c54ca1ebbe98..13efc424fff1 100644
--- a/sys-process/parallel/Manifest
+++ b/sys-process/parallel/Manifest
@@ -2,3 +2,5 @@ DIST parallel-20230722.tar.bz2 2527089 BLAKE2B d045e0cf2cbd2c1b9be69facdd3150fa4
DIST parallel-20230722.tar.bz2.sig 2080 BLAKE2B 82bfce506edda166ce4296e91e9119884aa4d52cc78326d5dce89f728fa2b8040679d2f8557c2a0555b00e6899601e24d5686b1903680511dd18eb3570b9c2f2 SHA512 2f38bc6c3b45cf2a91a5d3366400d1731a24088b939c0389e762f77b8127f411c9016d73cdfc5f7d3d86a9f33cc5cf6c3ccafc8fa49a6f970bf93d5cb4a28283
DIST parallel-20230822.tar.bz2 2507873 BLAKE2B cbf272623b92ad1fd1411e5f89e44855e07a2711b4b2573bf1bdca318efc3a5f3544eb8eec06f148e9af8d39d5a89c9e206029caad93d190091f14c8f158d046 SHA512 b28480abc83b819163c69b6cbba6ff51d9b4c9bdff08a910222be0a99307c21435473c42fc961ca5599c01f77f06870760ce01b9a9bbb1c80883ac756ac20f1d
DIST parallel-20230822.tar.bz2.sig 2080 BLAKE2B 3b7f4c636dd3a900bb724b75580f29a533f8785fe78048a8852e907cf92fb40d1c366a7cbc48de9e5ca1e3fd5754dd69fd3634d24ca1883d821d41089c065bcb SHA512 cc044a9890b7d37c4642d20002af7c86987badb47ce945a80b382d84a0c8ff5db21cbf8f374a5ac84132c295a8cb6e31476d59df03ad589ab0e790f874c47af8
+DIST parallel-20230922.tar.bz2 2507914 BLAKE2B 88053502e8c663d795f0752b4b13d1440629b1d657a1be6ea355f9afb625527875e5018baaa68e923b74d5b68ee854787062b76420480a1c63f3b4aad8247d82 SHA512 296aa4e1b53de9c0fe1d73bc1a1e96b436d95a053097053f6451ad4b0ad4489d6136b19623390070b60f84ce4a1248716d53addf47ba72a2f33013524d037da0
+DIST parallel-20230922.tar.bz2.sig 2080 BLAKE2B 460121de26a73e2880a2614b37b49b598628960e001a7e65b1157df557552b4f14617dc8f109505147e81dfcb824bc602a5a8e46b0e76b0a9b93b6a4f3640e5a SHA512 5024d4097822bdc7322a91dbf024dfc93a780002795885ae45c26f109917d748e4203ab5e27a6e18914c7cfa7e8b4c8dcf2ed945f4bed529c85ded2a2ad4693a
diff --git a/sys-process/parallel/parallel-20230922.ebuild b/sys-process/parallel/parallel-20230922.ebuild
new file mode 100644
index 000000000000..118f6be5fb2c
--- /dev/null
+++ b/sys-process/parallel/parallel-20230922.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/oletange.asc
+inherit verify-sig
+
+DESCRIPTION="A shell tool for executing jobs in parallel locally or on remote machines"
+HOMEPAGE="https://www.gnu.org/software/parallel/ https://git.savannah.gnu.org/cgit/parallel.git/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+SRC_URI+=" verify-sig? ( mirror://gnu/${PN}/${P}.tar.bz2.sig )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Devel-Size
+ dev-perl/Text-CSV
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ virtual/perl-IO
+"
+DEPEND="${RDEPEND}"
+BDEPEND="verify-sig? ( >=sec-keys/openpgp-keys-oletange-20210423 )"
+
+src_configure() {
+ # bug #908214
+ unset PARALLEL_HOME
+
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+}