summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-12-09 15:22:41 -0500
committerAaron Bauman <bman@gentoo.org>2019-12-09 15:29:28 -0500
commite61d694a5241a2323c3068c73ce3238c54f023a4 (patch)
tree6aed23497818537f615804be3864690893bfab3b /sys-libs
parentdev-embedded/tigcc: drop last-rited pkg (diff)
downloadgentoo-e61d694a5241a2323c3068c73ce3238c54f023a4.tar.gz
gentoo-e61d694a5241a2323c3068c73ce3238c54f023a4.tar.bz2
gentoo-e61d694a5241a2323c3068c73ce3238c54f023a4.zip
sys-*/*: drop last-rited pkgs
Closes: https://bugs.gentoo.org/697210 Closes: https://bugs.gentoo.org/697212 Closes: https://bugs.gentoo.org/697198 Closes: https://bugs.gentoo.org/697158 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libspe2/Manifest2
-rw-r--r--sys-libs/libspe2/files/spe.rc638
-rw-r--r--sys-libs/libspe2/libspe2-2.2.80_p95-r1.ebuild69
-rw-r--r--sys-libs/libspe2/libspe2-2.3.0_p135.ebuild70
-rw-r--r--sys-libs/libspe2/metadata.xml10
-rw-r--r--sys-libs/mars/Manifest1
-rw-r--r--sys-libs/mars/mars-1.0.1.ebuild43
-rw-r--r--sys-libs/mars/metadata.xml7
8 files changed, 0 insertions, 240 deletions
diff --git a/sys-libs/libspe2/Manifest b/sys-libs/libspe2/Manifest
deleted file mode 100644
index 72c6136e7632..000000000000
--- a/sys-libs/libspe2/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST libspe2-2.2.80-95.tar.gz 153122 BLAKE2B 80eb99c55c3d94bf1d9f77ca6925f5a606ce9b9845710084f5d50f6857706f780e6f3d77433105f3bdc1fa6873575b39e5edfdb0d6e817645013100c073b9afe SHA512 8ae0665e37f1ba98972f2906831007dfde2a35bb46b317604aee1327dd19ea8556a01d84c990ec6735004a7ee1e67439c0e0cba34f0df749f4e98766ca26021b
-DIST libspe2-2.3.0.135.tar.gz 197848 BLAKE2B 5d041e62b4301d84294a9be6f6c1881f39c7fadefc4f26ddf97bd2ff09a55ce8bcbd5deb752e4ef2453cac1b04edebabd58dbca80490435fafd5faf54286110c SHA512 31f4e9593d76de50ec5ab903aa82450fb5d9dea9300298831aeb408b083297ba88398fddc2110818bfdd5c13850cae95b9eced3b88f6627b732ea5a76e5d7435
diff --git a/sys-libs/libspe2/files/spe.rc6 b/sys-libs/libspe2/files/spe.rc6
deleted file mode 100644
index 76c1c5cb29d3..000000000000
--- a/sys-libs/libspe2/files/spe.rc6
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- # you need the elfspe bin
- need localmount
-}
-
-start() {
- ebegin "Registering elfspe to binfmt"
-
- if test -f /proc/sys/fs/binfmt_misc/spe
- then
- eerror "elfspe already registered"
- return 1
- else
- if test -f /proc/sys/fs/binfmt_misc/register
- then
- echo ':spe:M::\x7fELF\x01\x02\x01\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x02\x00\x17::/usr/bin/elfspe:' >/proc/sys/fs/binfmt_misc/register
- eend $?
- else
- eerror "binfmt not available"
- return 1
- fi
- fi
-}
-
-stop() {
- if ! test -f /proc/sys/fs/binfmt_misc/spe
- then
- eerror "elfspe not present"
- return 1
- else
- echo -1 > /proc/sys/fs/binfmt_misc/spe
- eend $?
- fi
-}
diff --git a/sys-libs/libspe2/libspe2-2.2.80_p95-r1.ebuild b/sys-libs/libspe2/libspe2-2.2.80_p95-r1.ebuild
deleted file mode 100644
index c98ead677fab..000000000000
--- a/sys-libs/libspe2/libspe2-2.2.80_p95-r1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit eutils
-
-MY_P=${P/_p/-}
-
-DESCRIPTION="A wrapper library to adapt the JSRE SPU usage model to SPUFS"
-HOMEPAGE="https://sourceforge.net/projects/libspe"
-SRC_URI="mirror://sourceforge/libspe/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="ppc ppc64"
-IUSE="debug"
-
-S="${WORKDIR}/${P//_p*}"
-
-DEPEND=""
-# This packages also provides libspe1
-RDEPEND="!sys-libs/libspe"
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- SYSROOT=""
-else
- SYSROOT="/usr/${CTARGET}"
-fi
-
-src_unpack () {
- unpack ${A}
- #just in case something is missing
- cd "${S}"
-}
-
-src_compile() {
- myconf=""
- use debug && myconf="${myconf} DEBUG=1"
- make all elfspe-all CROSS="${CTARGET}-" \
- prefix=/usr SYSROOT="$SYSROOT" ${myconf} \
- speinclude=/usr/spu-elf/include || die
-}
-
-src_install() {
- make CROSS="${CTARGET}-" prefix=/usr \
- speinclude=/usr/spu-elf/include \
- SYSROOT="$SYSROOT" \
- DESTDIR="$D" install elfspe-install || die
- newinitd "${FILESDIR}/spe.rc6" elfspe
-}
-
-pkg_postinst() {
- einfo "You may want to register elfspe to binfmt using the"
- einfo "provided initscript"
- einfo "# rc-update add elfspe boot"
- ewarn "make sure your fstab contains the following line"
- ewarn "none /spu spufs defaults
- 0 0"
- ewarn "and that you have spufs support enabled in the kernel"
-}
diff --git a/sys-libs/libspe2/libspe2-2.3.0_p135.ebuild b/sys-libs/libspe2/libspe2-2.3.0_p135.ebuild
deleted file mode 100644
index dbe65d54de60..000000000000
--- a/sys-libs/libspe2/libspe2-2.3.0_p135.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit eutils
-
-MY_P=${P/_p/.}
-
-DESCRIPTION="A wrapper library to adapt the JSRE SPU usage model to SPUFS"
-HOMEPAGE="https://sourceforge.net/projects/libspe"
-SRC_URI="mirror://sourceforge/libspe/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~ppc ~ppc64"
-IUSE="debug"
-
-S="${WORKDIR}/${P/_p*//}"
-
-DEPEND=""
-# This packages also provides libspe1
-RDEPEND="!sys-libs/libspe"
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- SYSROOT=""
-else
- SYSROOT="/usr/${CTARGET}"
-fi
-
-src_unpack () {
- unpack ${A}
- #just in case something is missing
- cd "${S}"
- echo "${S}"
-}
-
-src_compile() {
- myconf=""
- use debug && myconf="${myconf} DEBUG=1"
- make all elfspe-all CROSS="${CTARGET}-" \
- prefix=/usr SYSROOT="$SYSROOT" ${myconf} \
- speinclude=/usr/spu-elf/include || die
-}
-
-src_install() {
- make CROSS="${CTARGET}-" prefix=/usr \
- speinclude=/usr/spu-elf/include \
- SYSROOT="$SYSROOT" \
- DESTDIR="$D" install elfspe-install || die
- newinitd "${FILESDIR}/spe.rc6" elfspe
-}
-
-pkg_postinst() {
- einfo "You may want to register elfspe to binfmt using the"
- einfo "provided initscript"
- einfo "# rc-update add elfspe boot"
- ewarn "make sure your fstab contains the following line"
- ewarn "none /spu spufs defaults
- 0 0"
- ewarn "and that you have spufs support enabled in the kernel"
-}
diff --git a/sys-libs/libspe2/metadata.xml b/sys-libs/libspe2/metadata.xml
deleted file mode 100644
index 118d82b0c46f..000000000000
--- a/sys-libs/libspe2/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>lu_zero@gentoo.org</email>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">libspe</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/sys-libs/mars/Manifest b/sys-libs/mars/Manifest
deleted file mode 100644
index e509d51b07ba..000000000000
--- a/sys-libs/mars/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST mars-src-1.0.1.tar.gz 1264844 BLAKE2B 6e70174c0e62f33ba10f2cf793b1895cbfac2f879fe9d6d74509b4558d8991d2dc56946f5a429d854476cbef1a21ff12e60f6d09d69f2838f80892065b4a9bdd SHA512 56f46a19377b7c4058457082a54835d59ddae3c97e509eda1a977b637628edd352f14e0b2f8f8653e2f2de76ff73a5a4ed1b011213a7addc286c085a9c7c2a6e
diff --git a/sys-libs/mars/mars-1.0.1.ebuild b/sys-libs/mars/mars-1.0.1.ebuild
deleted file mode 100644
index d0ec58bb835e..000000000000
--- a/sys-libs/mars/mars-1.0.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit autotools
-
-MY_P=${P/mars/mars-src}
-
-DESCRIPTION="Multicore Application Runtime System"
-HOMEPAGE="ftp://ftp.infradead.org/pub/Sony-PS3/mars/"
-SRC_URI="ftp://ftp.infradead.org/pub/Sony-PS3/mars/1.0.1/${MY_P}.tar.gz"
-
-LICENSE="MIT_Plus MIT"
-SLOT="0"
-KEYWORDS="~ppc64"
-IUSE=""
-
-DEPEND="sys-libs/libspe2"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}/core"
-
-src_unpack () {
- unpack ${A}
- cd "${S}"
- # repeat after me: "dummy tuples are bogus"
- sed -i -e "s:/spu:/spu-elf:" \
- -e "s:--host=spu:--host=spu-elf:" configure.ac
- eautoreconf
-}
-
-src_compile () {
- unset CFLAGS
- unset CXXFLAGS
- unset CFLAGS_ppc64
- econf --with-mars-platform=cell || die
- emake || die
-}
-
-src_install () {
- emake -j1 DESTDIR="${D}" install
-}
diff --git a/sys-libs/mars/metadata.xml b/sys-libs/mars/metadata.xml
deleted file mode 100644
index dccede93222c..000000000000
--- a/sys-libs/mars/metadata.xml
+++ /dev/null
@@ -1,7 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="person">
- <email>lu_zero@gentoo.org</email>
-</maintainer>
-</pkgmetadata>