summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-02 01:16:13 +0000
committerSam James <sam@gentoo.org>2021-12-02 01:16:40 +0000
commita6396f527bae1a5d55bb63060713cd60b83cf323 (patch)
tree99fff5e68325d02f5c9fc79b5c94e6ffea9cf101 /sys-libs
parentsys-devel/gcc: Stabilize 11.2.0 hppa, #806586 (diff)
downloadgentoo-a6396f527bae1a5d55bb63060713cd60b83cf323.tar.gz
gentoo-a6396f527bae1a5d55bb63060713cd60b83cf323.tar.bz2
gentoo-a6396f527bae1a5d55bb63060713cd60b83cf323.zip
sys-libs/libxcrypt: add warning re distcc and older GCCs (<10)
Bug: https://bugs.gentoo.org/823179 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libxcrypt/libxcrypt-4.4.25-r1.ebuild11
-rw-r--r--sys-libs/libxcrypt/libxcrypt-4.4.26-r1.ebuild11
2 files changed, 22 insertions, 0 deletions
diff --git a/sys-libs/libxcrypt/libxcrypt-4.4.25-r1.ebuild b/sys-libs/libxcrypt/libxcrypt-4.4.25-r1.ebuild
index d8f01115f15c..d73e13788fd3 100644
--- a/sys-libs/libxcrypt/libxcrypt-4.4.25-r1.ebuild
+++ b/sys-libs/libxcrypt/libxcrypt-4.4.25-r1.ebuild
@@ -42,6 +42,17 @@ python_check_deps() {
has_version -b "dev-python/passlib[${PYTHON_USEDEP}]"
}
+pkg_pretend() {
+ if [[ ${BUILD_TYPE} != "binary" ]] && tc-is-gcc && [[ $(gcc-major-version) -lt 10 ]] ; then
+ die "libxcrypt is known to fail to build or be broken at runtime with < GCC 10 (bug #823179)!"
+ fi
+
+ if has "distcc" ${FEATURES} ; then
+ ewarn "Please verify all distcc nodes are using the same versions of GCC (>= 10) and Binutils!"
+ ewarn "Older/mismatched versions of GCC may lead to a misbehaving library: bug #823179."
+ fi
+}
+
pkg_setup() {
MULTIBUILD_VARIANTS=(
$(usex compat 'xcrypt_compat' '')
diff --git a/sys-libs/libxcrypt/libxcrypt-4.4.26-r1.ebuild b/sys-libs/libxcrypt/libxcrypt-4.4.26-r1.ebuild
index 5d0f0cffee7d..b25eb93a2469 100644
--- a/sys-libs/libxcrypt/libxcrypt-4.4.26-r1.ebuild
+++ b/sys-libs/libxcrypt/libxcrypt-4.4.26-r1.ebuild
@@ -42,6 +42,17 @@ python_check_deps() {
has_version -b "dev-python/passlib[${PYTHON_USEDEP}]"
}
+pkg_pretend() {
+ if [[ ${BUILD_TYPE} != "binary" ]] && tc-is-gcc && [[ $(gcc-major-version) -lt 10 ]] ; then
+ die "libxcrypt is known to fail to build or be broken at runtime with < GCC 10 (bug #823179)!"
+ fi
+
+ if has "distcc" ${FEATURES} ; then
+ ewarn "Please verify all distcc nodes are using the same versions of GCC (>= 10) and Binutils!"
+ ewarn "Older/mismatched versions of GCC may lead to a misbehaving library: bug #823179."
+ fi
+}
+
pkg_setup() {
MULTIBUILD_VARIANTS=(
$(usex compat 'xcrypt_compat' '')