summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2025-01-12 12:47:26 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2025-01-12 13:09:04 +0100
commit87f55e9ccac13f6381baec23d1250d4ab8166bc4 (patch)
tree93c3a86ad1caa21e7e4b19dd385d950661ba63d9 /sys-libs
parentapp-office/skrooge: add kde-invent upstream metadata (diff)
downloadgentoo-87f55e9ccac13f6381baec23d1250d4ab8166bc4.tar.gz
gentoo-87f55e9ccac13f6381baec23d1250d4ab8166bc4.tar.bz2
gentoo-87f55e9ccac13f6381baec23d1250d4ab8166bc4.zip
sys-libs/gwenhywfar: add 5.12.0
Closes: https://bugs.gentoo.org/921037 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/gwenhywfar/Manifest1
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-5.12.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/sys-libs/gwenhywfar/Manifest b/sys-libs/gwenhywfar/Manifest
index 17e89385ff99..c5cadeb4d462 100644
--- a/sys-libs/gwenhywfar/Manifest
+++ b/sys-libs/gwenhywfar/Manifest
@@ -1 +1,2 @@
DIST gwenhywfar-5.10.1.tar.gz 2687042 BLAKE2B 78fb776a605761f309060affef4e84e526ba789039f48f1e68e107d5002c508e19c9c2c2c0b3a8aba39c6c32543816914b504a6212219cfeeb4f0f04b0354f45 SHA512 11781bec2dd1c4156b609574283179278b8070d604a792aeddf92c8f9b873b3ac09273a8558b9adba567af8d016ea10914d2a149f4b6813798b5800e34e29aa5
+DIST gwenhywfar-5.12.0.tar.gz 2721790 BLAKE2B 99c875ff9de6908ebba92cda1fdca62a6c12d3c3994328b207e36003a0ce478abd6777a4a0a73669c9b85a28591429f14ca73a32695f7ee8d226a4aca69f9922 SHA512 0075eb626f0022ecd4ffdd59de7f0817d2def685e1d2cfbca9a32faa4b8d4d213bea631f24c5385da0b8c7743fd6d1887a46f08afa371195d911409ec7655791
diff --git a/sys-libs/gwenhywfar/gwenhywfar-5.12.0.ebuild b/sys-libs/gwenhywfar/gwenhywfar-5.12.0.ebuild
new file mode 100644
index 000000000000..aef1809cabc3
--- /dev/null
+++ b/sys-libs/gwenhywfar/gwenhywfar-5.12.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+DESCRIPTION="Multi-platform helper library for other libraries"
+HOMEPAGE="https://www.aquamaniac.de/sites/aqbanking/index.php"
+SRC_URI="https://www.aquamaniac.de/rdm/attachments/download/529/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/79" # correspond with libgwenhywfar.so version
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="debug doc gtk qt5 test"
+
+# broken upstream, reported but got no reply
+RESTRICT="test"
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ dev-libs/libgpg-error
+ dev-libs/libxml2:2
+ dev-libs/openssl:0=
+ net-libs/gnutls:=
+ virtual/libiconv
+ virtual/libintl
+ virtual/opengl
+ gtk? ( x11-libs/gtk+:3 )
+ qt5? (
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsql:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? ( app-text/doxygen )
+"
+
+src_configure() {
+ local myeconfargs=(
+ --with-docpath="${EPREFIX}/usr/share/doc/${PF}/apidoc"
+ --with-libxml2-code=yes
+ $(use_enable debug)
+ $(use_enable doc full-doc)
+ )
+ use qt5 && myeconfargs+=(
+ --with-qt5-moc="$(qt5_get_bindir)/moc"
+ --with-qt5-qmake="$(qt5_get_bindir)/qmake"
+ )
+
+ local guis=()
+ use gtk && guis+=( gtk3 )
+ use qt5 && guis+=( qt5 )
+ econf "${myeconfargs[@]}" "--with-guis=${guis[*]}"
+}
+
+src_compile() {
+ emake
+ use doc && emake srcdoc
+}
+
+src_install() {
+ default
+ use doc && emake DESTDIR="${D}" install-srcdoc
+ find "${D}" -name '*.la' -type f -delete || die
+}