summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2018-09-10 14:18:58 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2018-09-10 14:42:09 -0700
commite4b90363a83dc31ca7e5afdf425b25328e9c89a5 (patch)
treef3087401a91506c7790e82f6d8061799f50db1d6 /sys-libs/efivar/efivar-36.ebuild
parentmedia-gfx/gimp: Add gdbus-codegen to DEPEND of 9999 (diff)
downloadgentoo-e4b90363a83dc31ca7e5afdf425b25328e9c89a5.tar.gz
gentoo-e4b90363a83dc31ca7e5afdf425b25328e9c89a5.tar.bz2
gentoo-e4b90363a83dc31ca7e5afdf425b25328e9c89a5.zip
sys-libs/efivar: bump per fwupd testing
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'sys-libs/efivar/efivar-36.ebuild')
-rw-r--r--sys-libs/efivar/efivar-36.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-libs/efivar/efivar-36.ebuild b/sys-libs/efivar/efivar-36.ebuild
new file mode 100644
index 000000000000..93339047a52a
--- /dev/null
+++ b/sys-libs/efivar/efivar-36.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Tools and library to manipulate EFI variables"
+HOMEPAGE="https://github.com/rhinstaller/efivar"
+SRC_URI="https://github.com/rhinstaller/efivar/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~x86"
+
+RDEPEND="dev-libs/popt"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-3.18
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ sed -i -e 's/-Werror //' gcc.specs || die
+}
+
+src_configure() {
+ tc-export CC
+ export CC_FOR_BUILD=$(tc-getBUILD_CC)
+ tc-ld-disable-gold
+ export libdir="/usr/$(get_libdir)"
+ unset LIBS # Bug 562004
+
+ if [[ -n ${GCC_SPECS} ]]; then
+ # The environment overrides the command line.
+ GCC_SPECS+=":${S}/gcc.specs"
+ fi
+}