summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-27 12:23:21 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-27 14:04:10 +0100
commit763a9912b8e19e49c1f07fab9e234c966e1e2a34 (patch)
tree5026e45a8e0b8f0c43dce9663de7da2de1fe7b85 /sys-libs/cygwin-crypt/cygwin-crypt-1.4-r1.ebuild
parentkde-apps/kalarm: Drop IUSE X for now (diff)
downloadgentoo-763a9912b8e19e49c1f07fab9e234c966e1e2a34.tar.gz
gentoo-763a9912b8e19e49c1f07fab9e234c966e1e2a34.tar.bz2
gentoo-763a9912b8e19e49c1f07fab9e234c966e1e2a34.zip
sys-libs/cygwin-crypt: update EAPI 5 -> 8
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-libs/cygwin-crypt/cygwin-crypt-1.4-r1.ebuild')
-rw-r--r--sys-libs/cygwin-crypt/cygwin-crypt-1.4-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-libs/cygwin-crypt/cygwin-crypt-1.4-r1.ebuild b/sys-libs/cygwin-crypt/cygwin-crypt-1.4-r1.ebuild
new file mode 100644
index 000000000000..24de50f1790b
--- /dev/null
+++ b/sys-libs/cygwin-crypt/cygwin-crypt-1.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Cygwin Encryption/Decryption utility and library"
+HOMEPAGE="https://sourceware.org/cygwin-apps/"
+# Upstream provides the git repo only, so we do:
+# git clone git://cygwin.com/git/cygwin-apps/crypt.git
+# cd crypt
+# git archive -o cygwin-crypt-${PV}.tar --prefix=cygwin-crypt-${PV}/ crypt-${PV}-release
+# bzip2 cygwin-crypt-${PV}.tar
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~x64-cygwin"
+
+mymake() {
+ emake \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ CFLAGS="${CFLAGS}" \
+ prefix="${EPREFIX}/usr" \
+ docdir="${EPREFIX}/share/doc/${P}" \
+ "$@"
+}
+
+src_compile() {
+ mymake
+}
+
+src_install() {
+ mymake install DESTDIR="${D}"
+}