summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-06-16 18:30:43 -0400
committerMike Pagano <mpagano@gentoo.org>2024-06-16 18:30:43 -0400
commitde017a08009180c7503b62aaf8c5cbedd7758042 (patch)
tree013b2f7eaea8100ba5533964594df4236815ced8 /sys-kernel
parentapp-backup/bareos: enable py3.13 (diff)
downloadgentoo-de017a08009180c7503b62aaf8c5cbedd7758042.tar.gz
gentoo-de017a08009180c7503b62aaf8c5cbedd7758042.tar.bz2
gentoo-de017a08009180c7503b62aaf8c5cbedd7758042.zip
sys-kernel/git-sources: add 6.10_rc4
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.10_rc4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 2217a5212a27..c64be4fdbfb8 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -2,3 +2,4 @@ DIST linux-6.9.tar.xz 144034416 BLAKE2B 4cf86c3cfe6e6534745d42dfaeca59b17ea1168c
DIST patch-6.10-rc1.patch 40674461 BLAKE2B b9d366a5370007115f070c2817a12609a214019d2213e63f15c275a0cf62f343ab999127ef3a0f5c07d6e2ac25f8787d32f3f899ba25c822d1821a3be9a6a5a6 SHA512 ef437410403c1cbf74243aaa472564808b413827acebe300a1d571685b8d596febca6f07ecf4a3f6c2a9755d0b0da047d73ef165ffb569a15e58aa1b6f0e6c08
DIST patch-6.10-rc2.patch 40951045 BLAKE2B 45e99646253a45e4030ca70103d789e87f9d83a439875b81bd7902c6c180e41db4ac553909ac8fa109feecb303878ba3ac76ab5989430b32d196d726d81b0566 SHA512 8a326bf1f5132c6db9ca87f3d6e0d7657d33e15c64a805e56e8f6fd23df4ddd8ceb35c1059950e939f5562c3536d0981cfe560fe05fb5f7941ae23737ca630d2
DIST patch-6.10-rc3.patch 41282995 BLAKE2B b507c62020cb25bc3d7d7408222e018290c91689ffe27ffe89c082f2ed705b57e51d26f99613d80e6707adc2a1be7bf1909047122d5a9cbac973f2cd22f9d107 SHA512 4a5229973453c29fdbccc09f3cd015900ae457e5b1b3c5159256afdf30ff7644bdfe67724da90da7b9936308850725ae3c1066b71e966a695618593b0008e2bb
+DIST patch-6.10-rc4.patch 41531928 BLAKE2B a3945dbfd08a30ec82f8aeca668b2122be4d606ecc6d1a810bbc39d1eb0b69bedc9731cb98066eb8fd26447a8e6c57f7d523acdbed1f2a35be4a105f879c9f42 SHA512 efc88b09fe7cd5d54662a53aa94e9a6eb479f3e8de259903c8a4f7c9073cc9ef5dc16c2cc36c85296e35fca34758a93ceabcfe0600363c1a8b5383af8633ff55
diff --git a/sys-kernel/git-sources/git-sources-6.10_rc4.ebuild b/sys-kernel/git-sources/git-sources-6.10_rc4.ebuild
new file mode 100644
index 000000000000..edb1a477e11c
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.10_rc4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.9"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}