summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZen <z@pyl.onl>2024-09-22 13:23:45 -0500
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-09-23 16:43:39 +0200
commit25983688ef444ad46f052885ed78ba88e640b9ba (patch)
tree8a561542974ad57c7e22f8e21074d6e178e689dd /sys-kernel
parentsci-physics/yoda: add 2.0.1, 9999 (diff)
downloadgentoo-25983688ef444ad46f052885ed78ba88e640b9ba.tar.gz
gentoo-25983688ef444ad46f052885ed78ba88e640b9ba.tar.bz2
gentoo-25983688ef444ad46f052885ed78ba88e640b9ba.zip
sys-kernel/ugrd: add 1.22.0
Signed-off-by: Zen <z@pyl.onl> Closes: https://github.com/gentoo/gentoo/pull/38732 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ugrd/Manifest1
-rw-r--r--sys-kernel/ugrd/ugrd-1.22.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/sys-kernel/ugrd/Manifest b/sys-kernel/ugrd/Manifest
index 42fd5e528ebe..cbe0cf0bc8ba 100644
--- a/sys-kernel/ugrd/Manifest
+++ b/sys-kernel/ugrd/Manifest
@@ -1,3 +1,4 @@
DIST ugrd-1.13.0.tar.gz 63781 BLAKE2B 3f2d3095c6303b16947121071dabdbef81baaea5a7e208d53250e57edf136618497710ce3cca2906b87fbdc529b8a9ef119659365bba8c795594774cf8d096f6 SHA512 a745685668e981accfd32d1c47c6cf506ae63304ef5b3fdad200731db75b76fe56a4339876465bb1857c2fed35c273f95bbce390224fa0d01aebd67adbc31aa6
DIST ugrd-1.17.0.tar.gz 69517 BLAKE2B 2acadac8ab3830791146522ccfff6f8c5e98eff4cea355dafd5f5498bedf5d0f200ec2bc2ee4a20c62e3920590c70b2c788c776c148e7291cd3391eb2e0018df SHA512 5caeebadb579536a60cecd6c9fd9036c178ab5c5700418b95841e7102ac0c3c5fa14ceebc9994a86f65bd0623ca819ed7cb7a986f412e0358c9597c0e579f90c
DIST ugrd-1.20.0.tar.gz 64541 BLAKE2B d85241e6c0822d3df0d65cc07cb17014b4d66554476caf4d37ebc77943c57ef3004e1e01b4eb504974b2ab9d1a03015812e8b0cb19ebf03667a9f6c7a1bded03 SHA512 88f137fa5fc4cb61418cda03c0c58ff7632c1e61b7688ad9e8cce538842d817e973c1d2293b8bb92b9697a29511cb535059ca060793ba6353d95d5ddad417f3a
+DIST ugrd-1.22.0.tar.gz 65955 BLAKE2B 0573364964ce8d874ff126e87e003aeb90d3f6460ecaca7aaf5f231fe9069dca9239c0ee9e68157eebaab8651401df0c22695d5a81e2984dbfb89b4a38f5a0aa SHA512 78598f0b0d81a9528b84fd829269b7ce0588830bf95ce5e6455c02053e38a25dd9eecb664057ea6bfed653590c39f73dd3f4a4235e056d27c9c100b166a29996
diff --git a/sys-kernel/ugrd/ugrd-1.22.0.ebuild b/sys-kernel/ugrd/ugrd-1.22.0.ebuild
new file mode 100644
index 000000000000..6869d9c50265
--- /dev/null
+++ b/sys-kernel/ugrd/ugrd-1.22.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+inherit distutils-r1 optfeature shell-completion
+
+DESCRIPTION="Python based initramfs generator with TOML defintions"
+HOMEPAGE="https://github.com/desultory/ugrd"
+SRC_URI="https://github.com/desultory/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ app-misc/pax-utils
+ >=dev-python/zenlib-2.2.3[${PYTHON_USEDEP}]
+ >=dev-python/pycpio-1.3.2[${PYTHON_USEDEP}]
+ sys-apps/pciutils
+"
+
+BDEPEND="
+ test? (
+ amd64? ( app-emulation/qemu[qemu_softmmu_targets_x86_64] )
+ arm64? ( app-emulation/qemu[qemu_softmmu_targets_aarch64] )
+ )
+"
+
+python_install_all() {
+ # Call the distutils-r1_python_install_all function
+ distutils-r1_python_install_all
+ # Install the example config into /etc/ugrd/config.toml
+ # Do not overwrite an existing config
+ insinto /etc/ugrd
+ newins examples/example.toml config.toml
+
+ # Install the kernel preinst.d hook
+ exeinto /usr/lib/kernel/preinst.d
+ doexe hooks/installkernel/52-ugrd.install
+ exeinto /usr/lib/kernel/install.d
+ doexe hooks/kernel-install/52-ugrd.install
+
+ dobashcomp completion/ugrd # Install bash autocomplete script
+ dozshcomp completion/_ugrd # Install zsh autocomplete script
+}
+
+pkg_postinst() {
+ optfeature "ugrd.crypto.cryptsetup support" sys-fs/cryptsetup
+ optfeature "ugrd.fs.btrfs support" sys-fs/btrfs-progs
+ optfeature "ugrd.crypto.gpg support" app-crypt/gnupg
+ optfeature "ugrd.fs.lvm support" sys-fs/lvm2[lvm]
+}
+
+distutils_enable_tests unittest
+
+src_test() {
+ if [[ ! -w '/dev/kvm' ]]; then
+ ewarn "Skipping tests: Cannot write to /dev/kvm."
+ return 1
+ fi
+ if [[ ! -r "$(command -v mount)" ]]; then
+ ewarn "Cannot read the mount binary, tests may fail until"
+ ewarn "util-linux is re-emerged without the sfperms feature."
+ fi
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ eunittest tests/
+}