summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-07-01 19:55:22 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-07-01 19:55:22 +0200
commit8d97ba8e872340f21b2739a25c6d397c396d57ae (patch)
tree5f841a1ccc0cad7f35adac838f917238b70cfe18 /sys-kernel/linux-firmware
parentnet-im/discord: enable explicit wayland support (diff)
downloadgentoo-8d97ba8e872340f21b2739a25c6d397c396d57ae.tar.gz
gentoo-8d97ba8e872340f21b2739a25c6d397c396d57ae.tar.bz2
gentoo-8d97ba8e872340f21b2739a25c6d397c396d57ae.zip
sys-kernel/linux-firmware: fix USE=initramfs in live, sync live
Closes: https://bugs.gentoo.org/935288 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-kernel/linux-firmware')
-rw-r--r--sys-kernel/linux-firmware/linux-firmware-99999999.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild b/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
index 144bba36cba3..17a10c80a0fc 100644
--- a/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
+++ b/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
@@ -19,7 +19,7 @@ else
SRC_URI="https://mirrors.edge.kernel.org/pub/linux/kernel/firmware/${P}.tar.xz"
fi
- KEYWORDS="~amd64"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
DESCRIPTION="Linux firmware files"
@@ -66,6 +66,18 @@ IDEPEND="
QA_PREBUILT="*"
+pkg_pretend() {
+ if use initramfs; then
+ if [[ -z ${ROOT} ]] && use dist-kernel; then
+ # Check, but don't die because we can fix the problem and then
+ # emerge --config ... to re-run installation.
+ nonfatal mount-boot_check_status
+ else
+ mount-boot_pkg_pretend
+ fi
+ fi
+}
+
pkg_setup() {
if use compress-xz || use compress-zstd ; then
local CONFIG_CHECK
@@ -83,18 +95,6 @@ pkg_setup() {
linux-info_pkg_setup
}
-pkg_pretend() {
- if use initramfs; then
- if [[ -z ${ROOT} ]] && use dist-kernel; then
- # Check, but don't die because we can fix the problem and then
- # emerge --config ... to re-run installation.
- nonfatal mount-boot_check_status
- else
- mount-boot_pkg_pretend
- fi
- fi
-}
-
src_unpack() {
if [[ ${PV} == 99999999* ]]; then
git-r3_src_unpack
@@ -120,7 +120,7 @@ src_prepare() {
if use initramfs && ! use dist-kernel; then
if [[ -d "${S}/amd-ucode" ]]; then
- ."/${T}/make-amd-ucode-img" "${S}/amd-ucode" "${S}/amd-ucode.img" || die
+ "${T}/make-amd-ucode-img" "${S}" "${S}/amd-ucode" || die
else
# If this will ever happen something has changed which
# must be reviewed