summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2022-02-13 15:37:42 -0500
committerMike Pagano <mpagano@gentoo.org>2022-02-13 15:37:48 -0500
commit59ae19eae24bc72661351a25c31694d3293e08cc (patch)
tree1a63d1633ba1d9a549e8460bc1db579e5b50f6e7 /sys-kernel/git-sources
parentapp-crypt/mkp224o: initial import at 1.5.0 (diff)
downloadgentoo-59ae19eae24bc72661351a25c31694d3293e08cc.tar.gz
gentoo-59ae19eae24bc72661351a25c31694d3293e08cc.tar.bz2
gentoo-59ae19eae24bc72661351a25c31694d3293e08cc.zip
sys-kernel/git-sources: Linux patch 5.17-rc4
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.17_rc4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index d61db123f7d1..4e965353aa2e 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -2,3 +2,4 @@ DIST linux-5.16.tar.xz 123114100 BLAKE2B 07a90cc640ff89e1359c06cee8c38abd33e51f9
DIST patch-5.17-rc1.patch 36453946 BLAKE2B a600f68e504c7602098dd0bb26f405b1bca318baaaeb479d6b5b0a0483d5aa5f9baaeb2f1d3f53734821dfbd2a77be4cf7fa4f7057b5c6ae7fe9b6c068b0cd12 SHA512 0de5045d74ae2e64c40fc482879152ff0b696eba2618cda66e231e70afe8e1d18d946bfcfda50d5c037ab90e11f9777d558b4fdef785f9777b8f97959551ee65
DIST patch-5.17-rc2.patch 36928215 BLAKE2B 3ae1f09eeb870fda422db561ca1adfd68c7ea96ddcd47672028d6ccc44c49eca5fe53e77b0173bd66be04883f7dc0a65addd55b435dd0f8d4fb7418a21d6a8d2 SHA512 dd10a6c88da50ca9e0a37aa1377b86122c56a50a8c608a02dd425ac23ee20418b29fe2332981bdffa45d2ac44b3b4a9e294fb786ba7c13c01ec821b6915cdb56
DIST patch-5.17-rc3.patch 37376734 BLAKE2B 40564254d729bdad9860b48a51657b6a3cef681b9f4add643d7a7e8bd80511cc3da9ec7257acd355a23cde8f1c8e51286560a168ad951100c9139057518d64f6 SHA512 d5c6444f73a1d0099ed9c3f1c35e7d0e6df487b9897d57b5f9d4d787df210dd8a2fb58c428a13844c5c846007fe5f349860503187690ed83f846b867377d5cf1
+DIST patch-5.17-rc4.patch 37600999 BLAKE2B f5839b3f9cf1c7ec4e49ae29d27525a9bce1f244fbfbd30b4b2f9b35761873e74d79a36e4ecb619ce91d04829164b8e347a3c23d66fbef677619f0f8e51498d2 SHA512 54a3e37bad6e223b09bebe97f5188cbbbc38ada271611d817aa2d033895c602bfb989fcd028004507a0ab5063af532d3f5a16424f574f24d78e6962eb460998c
diff --git a/sys-kernel/git-sources/git-sources-5.17_rc4.ebuild b/sys-kernel/git-sources/git-sources-5.17_rc4.ebuild
new file mode 100644
index 000000000000..b7eedd7884ba
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.17_rc4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.16"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}