summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2021-01-23 13:45:23 -0500
committerMike Pagano <mpagano@gentoo.org>2021-01-23 13:45:27 -0500
commit9b26e86a79c471a8c6bb4daa854f117ab65a025a (patch)
tree6a518ed9b07d96059295e6465a0cff9a070c0899 /sys-kernel/gentoo-sources/gentoo-sources-4.4.253.ebuild
parentpackage.mask: Extend binutils mask (diff)
downloadgentoo-9b26e86a79c471a8c6bb4daa854f117ab65a025a.tar.gz
gentoo-9b26e86a79c471a8c6bb4daa854f117ab65a025a.tar.bz2
gentoo-9b26e86a79c471a8c6bb4daa854f117ab65a025a.zip
sys-kernel/gentoo-sources: Linux patch updates and wireguard fix
Linux patch 4.14.217 Linux patch 4.19.170 Linux patch 4.4.253 Linux patch 4.9.253 Linux patch 5.4.92 Linux patch 5.10.10 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-4.4.253.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-4.4.253.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-4.4.253.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-4.4.253.ebuild
new file mode 100644
index 000000000000..4856aa05c1d6
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-4.4.253.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="255"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}