summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-08-05 16:21:20 +0200
committerZac Medico <zmedico@gentoo.org>2024-08-05 17:28:42 -0700
commit5ed91a25cb4038e0ca0a1da891a9f9a9999f3cd5 (patch)
tree144bb139b166295b79b505a898ad9f8d7d8d06fd /sys-fabric
parentsys-fabric/mstflint: drop 4.18.0_p1-r1, 4.20.0_p1 (diff)
downloadgentoo-5ed91a25cb4038e0ca0a1da891a9f9a9999f3cd5.tar.gz
gentoo-5ed91a25cb4038e0ca0a1da891a9f9a9999f3cd5.tar.bz2
gentoo-5ed91a25cb4038e0ca0a1da891a9f9a9999f3cd5.zip
sys-fabric/mstflint: fix pkgcheck issues
Signed-off-by: Filip Kobierski <fkobi@pm.me> Closes: https://github.com/gentoo/gentoo/pull/37978 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'sys-fabric')
-rw-r--r--sys-fabric/mstflint/mstflint-4.23.0_p1.ebuild25
1 files changed, 15 insertions, 10 deletions
diff --git a/sys-fabric/mstflint/mstflint-4.23.0_p1.ebuild b/sys-fabric/mstflint/mstflint-4.23.0_p1.ebuild
index 44fd3ec31adb..625933e4b2ff 100644
--- a/sys-fabric/mstflint/mstflint-4.23.0_p1.ebuild
+++ b/sys-fabric/mstflint/mstflint-4.23.0_p1.ebuild
@@ -1,21 +1,25 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit autotools
+MY_PV="${PV/_p/-}"
+EGIT_COMMIT="acfaf553f2f571b1f9256b6cd558eafa767d9172"
+
DESCRIPTION="Mstflint - an open source version of MFT (Mellanox Firmware Tools)"
HOMEPAGE="https://github.com/Mellanox/mstflint"
+SRC_URI="https://github.com/Mellanox/mstflint/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
LICENSE="|| ( GPL-2 BSD-2 )"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
-EGIT_COMMIT="acfaf553f2f571b1f9256b6cd558eafa767d9172"
-MY_PV=${PV/_p/-}
-MY_P=""
-SRC_URI="https://github.com/Mellanox/mstflint/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
IUSE="adb-generic-tools inband ssl"
-SLOT="0"
-RDEPEND="dev-db/sqlite:3=
+
+RDEPEND="
+ dev-db/sqlite:3=
sys-libs/zlib:=
inband? ( sys-cluster/rdma-core )
adb-generic-tools? (
@@ -24,8 +28,8 @@ RDEPEND="dev-db/sqlite:3=
)
ssl? ( dev-libs/openssl:= )"
DEPEND="${RDEPEND}"
-S="${WORKDIR}/${PN}-${MY_PV}"
-PATCHES=("${FILESDIR}"/mstflint-4.23.0_p1-C99-compat.patch)
+
+PATCHES=( "${FILESDIR}"/mstflint-4.23.0_p1-C99-compat.patch )
src_prepare() {
default
@@ -36,7 +40,8 @@ src_prepare() {
src_configure() {
eautoreconf
- econf $(use_enable inband) $(use_enable ssl openssl) $(use adb-generic-tools && printf -- '--enable-adb-generic-tools')
+ econf $(use_enable inband) $(use_enable ssl openssl) \
+ $(use adb-generic-tools && printf -- '--enable-adb-generic-tools')
}
src_compile() {