summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-15 18:53:09 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-15 18:54:54 +0200
commit90ce46cb47f1c6205dec81c439aa5ebdc278e6eb (patch)
tree92ce00b699bc9c4cce3cf297bd349a07e2f98682 /sys-devel/llvm
parentsys-devel/clang: Backport test fix (related to UB fix) to 14.0.6-r4 (diff)
downloadgentoo-90ce46cb47f1c6205dec81c439aa5ebdc278e6eb.tar.gz
gentoo-90ce46cb47f1c6205dec81c439aa5ebdc278e6eb.tar.bz2
gentoo-90ce46cb47f1c6205dec81c439aa5ebdc278e6eb.zip
sys-devel/llvm: Remove obsolete -flto filtering from live ebuilds
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/llvm-16.0.4.9999.ebuild7
-rw-r--r--sys-devel/llvm/llvm-17.0.0.9999.ebuild7
2 files changed, 6 insertions, 8 deletions
diff --git a/sys-devel/llvm/llvm-16.0.4.9999.ebuild b/sys-devel/llvm/llvm-16.0.4.9999.ebuild
index 6b874a5fe20f..840748f0601b 100644
--- a/sys-devel/llvm/llvm-16.0.4.9999.ebuild
+++ b/sys-devel/llvm/llvm-16.0.4.9999.ebuild
@@ -4,8 +4,9 @@
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit cmake llvm.org multilib-minimal pax-utils python-any-r1 \
- toolchain-funcs flag-o-matic
+
+inherit cmake llvm.org multilib-minimal pax-utils python-any-r1
+inherit toolchain-funcs
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="https://llvm.org/"
@@ -324,8 +325,6 @@ get_distribution_components() {
}
multilib_src_configure() {
- tc-is-gcc && filter-lto # GCC miscompiles LLVM, bug #873670
-
local ffi_cflags ffi_ldflags
if use libffi; then
ffi_cflags=$($(tc-getPKG_CONFIG) --cflags-only-I libffi)
diff --git a/sys-devel/llvm/llvm-17.0.0.9999.ebuild b/sys-devel/llvm/llvm-17.0.0.9999.ebuild
index 1ae16d3ef49a..c2c2d7c6b628 100644
--- a/sys-devel/llvm/llvm-17.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-17.0.0.9999.ebuild
@@ -4,8 +4,9 @@
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit cmake llvm.org multilib-minimal pax-utils python-any-r1 \
- toolchain-funcs flag-o-matic
+
+inherit cmake llvm.org multilib-minimal pax-utils python-any-r1
+inherit toolchain-funcs
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="https://llvm.org/"
@@ -338,8 +339,6 @@ get_distribution_components() {
}
multilib_src_configure() {
- tc-is-gcc && filter-lto # GCC miscompiles LLVM, bug #873670
-
local ffi_cflags ffi_ldflags
if use libffi; then
ffi_cflags=$($(tc-getPKG_CONFIG) --cflags-only-I libffi)