summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-03-13 22:10:48 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-03-13 22:20:24 +0000
commitf8a6fa80e0d463b369defc387ba6e78f29cd67c7 (patch)
tree0cc62ffc9eb4c584906d8f69a9419b707e93dba6 /sys-devel/gdb/gdb-9999.ebuild
parentdev-util/trace-cmd: Revbump, drop "gtk" USE flag (diff)
downloadgentoo-f8a6fa80e0d463b369defc387ba6e78f29cd67c7.tar.gz
gentoo-f8a6fa80e0d463b369defc387ba6e78f29cd67c7.tar.bz2
gentoo-f8a6fa80e0d463b369defc387ba6e78f29cd67c7.zip
sys-devel/gdb: add source-highlight depend, bug #680238
Found and diagnosed by Jeroen Roovers. Patch proposed upstream as: https://sourceware.org/ml/gdb-patches/2019-03/msg00285.html Reported-by: Jeroen Roovers Closes: https://bugs.gentoo.org/680238 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/gdb/gdb-9999.ebuild')
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 5141bb241473..f9e1edcd7cc8 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -62,7 +62,7 @@ SLOT="0"
if [[ ${PV} != 9999* ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
-IUSE="+client lzma multitarget nls +python +server test vanilla xml"
+IUSE="+client lzma multitarget nls +python +server source-highlight test vanilla xml"
REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
|| ( client server )
@@ -78,7 +78,11 @@ RDEPEND="
python? ( ${PYTHON_DEPS} )
xml? ( dev-libs/expat )
sys-libs/zlib
- )"
+ )
+ source-highlight? (
+ dev-util/source-highlight
+ )
+"
DEPEND="${RDEPEND}"
BDEPEND="
app-arch/xz-utils
@@ -165,6 +169,7 @@ src_configure() {
$(use_with xml expat)
$(use_with lzma)
$(use_enable nls)
+ $(use_enable source-highlight)
$(use multitarget && echo --enable-targets=all)
$(use_with python python "${EPYTHON}")
)