summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2025-01-11 08:35:02 +0000
committerSam James <sam@gentoo.org>2025-01-11 08:35:19 +0000
commit6d992feaa6205ba648ae07cedd39c944362fbab3 (patch)
treede38cc680e4638fdf0918cd26718f431353a2b69 /sys-devel/binutils
parentapp-containers/sen: enable py3.13 (diff)
downloadgentoo-6d992feaa6205ba648ae07cedd39c944362fbab3.tar.gz
gentoo-6d992feaa6205ba648ae07cedd39c944362fbab3.tar.bz2
gentoo-6d992feaa6205ba648ae07cedd39c944362fbab3.zip
sys-devel/binutils: workaround ifcombine bug
Bug: https://gcc.gnu.org/PR118409 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/binutils')
-rw-r--r--sys-devel/binutils/binutils-2.43-r2.ebuild5
-rw-r--r--sys-devel/binutils/binutils-9999.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/sys-devel/binutils/binutils-2.43-r2.ebuild b/sys-devel/binutils/binutils-2.43-r2.ebuild
index ec5d17d21413..92f81b799d4b 100644
--- a/sys-devel/binutils/binutils-2.43-r2.ebuild
+++ b/sys-devel/binutils/binutils-2.43-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -185,6 +185,9 @@ src_configure() {
use cet && filter-flags -mindirect-branch -mindirect-branch=*
use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
+ # Workaround for gcc PR118409
+ tc-is-gcc && [[ $(gcc-major-version) -eq 15 ]] && append-flags -fdisable-tree-ifcombine
+
# https://sourceware.org/PR32372
append-cflags $(test-flags-CC -std=gnu17)
diff --git a/sys-devel/binutils/binutils-9999.ebuild b/sys-devel/binutils/binutils-9999.ebuild
index b262083b7c2f..0104b56227f6 100644
--- a/sys-devel/binutils/binutils-9999.ebuild
+++ b/sys-devel/binutils/binutils-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -192,6 +192,9 @@ src_configure() {
use cet && filter-flags -mindirect-branch -mindirect-branch=*
use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
+ # Workaround for gcc PR118409
+ tc-is-gcc && [[ $(gcc-major-version) -eq 15 ]] && append-flags -fdisable-tree-ifcombine
+
local x
echo
for x in CATEGORY CBUILD CHOST CTARGET CFLAGS LDFLAGS ; do