summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-03-26 16:21:28 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-03-26 16:21:28 +0200
commit38fff1c0b0755611427a4017c386a18fcca8f122 (patch)
treed51cfd8e133190494ff601ae2d968da4f463df1c /sys-cluster
parentx11-plugins/enigmail: Bump to version 2.0. Removed old. (diff)
downloadgentoo-38fff1c0b0755611427a4017c386a18fcca8f122.tar.gz
gentoo-38fff1c0b0755611427a4017c386a18fcca8f122.tar.bz2
gentoo-38fff1c0b0755611427a4017c386a18fcca8f122.zip
sys-cluster/minikube: Version bump to 0.25.2
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/minikube/Manifest1
-rw-r--r--sys-cluster/minikube/minikube-0.25.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-cluster/minikube/Manifest b/sys-cluster/minikube/Manifest
index efffca064cac..40eee7260c4c 100644
--- a/sys-cluster/minikube/Manifest
+++ b/sys-cluster/minikube/Manifest
@@ -1 +1,2 @@
DIST minikube-0.25.0.tar.gz 19657702 BLAKE2B 5b396f2720300e56096f62956d429ff33999b956f80857131b3c89e33f11917a461d11982531744acc31bf62b7f365ca6e909fd50336f1440acff1889e374815 SHA512 43cd2be9b48cf44ade46936157e2654a81a773a055aaa4239c232e42ee769d9e165b02c43d8dce6a09396c30e46ec811f08ed0fb9a2c81f13db76e13ab03ef54
+DIST minikube-0.25.2.tar.gz 19765563 BLAKE2B 6830cb402ed29e7a976b2bbe418fe41051b295414d38b88a4d35e7352923b96aacd5f4d80458e53c3ae752d3e53b86e0b8a823c317271e4efd201db27eafb029 SHA512 505dea2ddee96ddd476429f05bcf889c99f60a38fee21b4724f528253037ae268ebac2830c38d331f14f47a689afc2dec2d6815983dd0aee4c5bb7ff58f67f9d
diff --git a/sys-cluster/minikube/minikube-0.25.2.ebuild b/sys-cluster/minikube/minikube-0.25.2.ebuild
new file mode 100644
index 000000000000..8f9d3252d27a
--- /dev/null
+++ b/sys-cluster/minikube/minikube-0.25.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit python-any-r1 golang-build golang-vcs-snapshot
+
+EGO_PN="k8s.io/minikube"
+ARCHIVE_URI="https://github.com/kubernetes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Single Node Kubernetes Cluster"
+HOMEPAGE="https://github.com/kubernetes/minikube https://kubernetes.io"
+SRC_URI="${ARCHIVE_URI}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened"
+
+DEPEND="dev-go/go-bindata
+ ${PYTHON_DEPS}"
+RDEPEND=">=sys-cluster/kubectl-1.9.4"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ sed -i -e 's/ -s -w/ -w/' -e 's#$(GOPATH)/bin/go-bindata#go-bindata#' -e 's#GOBIN=$(GOPATH)/bin go get github.com/jteeuwen/go-bindata/...##' src/${EGO_PN}/Makefile || die
+ sed -i -e "s/get_rev(), get_version(), get_tree_state()/get_rev(), get_version(), 'gitTreeState=clean'/" src/${EGO_PN}/hack/get_k8s_version.py || die
+}
+
+src_compile() {
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
+ LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -C src/${EGO_PN}
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin out/minikube
+ dodoc -r docs CHANGELOG.md README.md
+ popd || die
+}