summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-03-22 17:42:37 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-03-22 17:43:39 +0300
commit419b93d8247885c1c024db833b9404e112622dfb (patch)
tree744810795331ce51d68489ff252b6da6ff664253 /sys-cluster/openmpi
parentmedia-libs/osl: Restrict 1.10.5 to <sys-devel/clang-9 (diff)
downloadgentoo-419b93d8247885c1c024db833b9404e112622dfb.tar.gz
gentoo-419b93d8247885c1c024db833b9404e112622dfb.tar.bz2
gentoo-419b93d8247885c1c024db833b9404e112622dfb.zip
sys-cluster/openmpi: migrate 1.6.5 to EAPI=7
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'sys-cluster/openmpi')
-rw-r--r--sys-cluster/openmpi/openmpi-1.6.5-r1.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/sys-cluster/openmpi/openmpi-1.6.5-r1.ebuild b/sys-cluster/openmpi/openmpi-1.6.5-r1.ebuild
index 2e0401287fb9..3c25f065ce3a 100644
--- a/sys-cluster/openmpi/openmpi-1.6.5-r1.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.6.5-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
FORTRAN_NEEDED=fortran
-inherit autotools eutils fortran-2 multilib flag-o-matic toolchain-funcs versionator
+inherit autotools fortran-2 flag-o-matic toolchain-funcs
MY_P=${P/-mpi}
S=${WORKDIR}/${MY_P}
@@ -31,7 +31,7 @@ IUSE_OPENMPI_OFED_FEATURES="
DESCRIPTION="A high-performance message passing library (MPI)"
HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v$(get_version_component_range 1-2)/downloads/${MY_P}.tar.bz2"
+SRC_URI="http://www.open-mpi.org/software/ompi/v$(ver_cut 1-2)/downloads/${MY_P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
@@ -88,6 +88,7 @@ pkg_setup() {
}
src_prepare() {
+ default
# Necessary for scalibility, see
# http://www.open-mpi.org/community/lists/users/2008/09/6514.php
if use threads; then
@@ -97,10 +98,10 @@ src_prepare() {
# https://svn.open-mpi.org/trac/ompi/ticket/3649
# https://svn.open-mpi.org/trac/ompi/ticket/3648
- epatch "${FILESDIR}"/hooks-disable-malloc-override-inside-of-Gentoo-sandb.patch
+ eapply "${FILESDIR}"/hooks-disable-malloc-override-inside-of-Gentoo-sandb.patch
# https://github.com/open-mpi/ompi/issues/163
- epatch "${FILESDIR}"/openmpi-ltdl.patch
+ eapply "${FILESDIR}"/openmpi-ltdl.patch
AT_M4DIR="config opal/config orte/config ompi/config" eautoreconf
}
@@ -154,9 +155,9 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install
+ default
# From USE=vt see #359917
- rm "${ED}"/usr/share/libtool &> /dev/null
+ rm "${ED}"/usr/share/libtool || die
dodoc README AUTHORS NEWS VERSION
}