summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-18 07:00:07 +0100
committerSam James <sam@gentoo.org>2023-04-18 07:00:51 +0100
commit798f77a3a5d65ecea6175fec8f0482cd89605b90 (patch)
tree1e92b3202523b7a520998dc980768fee8caca7e4 /sys-cluster/legion
parentapp-admin/clog: add github upstream metadata (diff)
downloadgentoo-798f77a3a5d65ecea6175fec8f0482cd89605b90.tar.gz
gentoo-798f77a3a5d65ecea6175fec8f0482cd89605b90.tar.bz2
gentoo-798f77a3a5d65ecea6175fec8f0482cd89605b90.zip
sys-cluster/legion: add 23.03.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster/legion')
-rw-r--r--sys-cluster/legion/Manifest1
-rw-r--r--sys-cluster/legion/files/legion-23.03.0-gcc13.patch24
-rw-r--r--sys-cluster/legion/legion-23.03.0.ebuild47
3 files changed, 72 insertions, 0 deletions
diff --git a/sys-cluster/legion/Manifest b/sys-cluster/legion/Manifest
index 52753eefc567..8096fecd1bdb 100644
--- a/sys-cluster/legion/Manifest
+++ b/sys-cluster/legion/Manifest
@@ -1 +1,2 @@
DIST legion-21.09.0.tar.gz 4017440 BLAKE2B 8f2919ed89f94cd12aff761de0e91ea0b5f9fd6001b83f69f8aff4703df159f001c562ed62ac22404fb15ebecc86a175d7acb528aba2e2d05ef7a6e6c0a9d830 SHA512 ffdbc8fa50100b7feb1709299dc1a9d01f14a6368812a6c5c16fa58746e9627f20863060c3ca25fd8865c8569c5a5f274a0298902bb82f6567b05299f55f6f75
+DIST legion-23.03.0.tar.gz 4330417 BLAKE2B efcc1f071fb7d9a03e03c4640976961634c6c630186c3cb2314098ae4260ba15b65739743eb355ad7dd74454d1e07542e9a58dbe558b652f0bf788811ff94ed1 SHA512 0a07fc3913fb1108c4b0d3ba9af80464f0acc1f69727dd9271a4f98f1ed7cc51a2e97699a16f0ebd437a0fa47933f1aa78c4cbc0401d332a432d1e839d39201c
diff --git a/sys-cluster/legion/files/legion-23.03.0-gcc13.patch b/sys-cluster/legion/files/legion-23.03.0-gcc13.patch
new file mode 100644
index 000000000000..6c0eed1e15c7
--- /dev/null
+++ b/sys-cluster/legion/files/legion-23.03.0-gcc13.patch
@@ -0,0 +1,24 @@
+https://github.com/StanfordLegion/legion/pull/1461
+
+From 6165e09b8d990bd5c6baa7b7a487b6757d89d3e3 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 18 Apr 2023 06:54:38 +0100
+Subject: [PATCH] Fix build with GCC 13
+
+GCC 13 (as usual for new compiler releases) shuffles around some internal includes so some
+are no longer transitively included.
+
+See https://gnu.org/software/gcc/gcc-13/porting_to.html.
+
+Bug: https://bugs.gentoo.org/895564
+--- a/runtime/realm/utils.h
++++ b/runtime/realm/utils.h
+@@ -27,6 +27,7 @@
+ #include <vector>
+ #include <map>
+ #include <cassert>
++#include <cstdint>
+ #include <sstream>
+
+ namespace Realm {
+
diff --git a/sys-cluster/legion/legion-23.03.0.ebuild b/sys-cluster/legion/legion-23.03.0.ebuild
new file mode 100644
index 000000000000..95cdbf4b0a3c
--- /dev/null
+++ b/sys-cluster/legion/legion-23.03.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A data-centric parallel programming system"
+HOMEPAGE="https://legion.stanford.edu/"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://StanfordLegion/${PN}.git https://github.com/StanfordLegion/${PN}.git"
+else
+ SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${P}
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples gasnet hwloc test"
+RESTRICT="!test? ( test )"
+
+# https://github.com/StanfordLegion/legion/issues/575 re <hwloc-2
+# See bug #821424 for examples/mpi
+DEPEND="examples? ( virtual/mpi[cxx] )
+ gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
+ hwloc? ( <sys-apps/hwloc-2:= )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-23.03.0-gcc13.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DLegion_USE_HWLOC=$(usex hwloc)
+ -DLegion_USE_GASNet=$(usex gasnet)
+ -DLegion_ENABLE_TESTING=$(usex test)
+ -DLegion_BUILD_EXAMPLES=$(usex examples)
+ -DLegion_BUILD_TESTS=ON
+ -DLegion_BUILD_TUTORIAL=ON
+ )
+
+ cmake_src_configure
+}