summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-01 14:37:02 +0100
committerSam James <sam@gentoo.org>2023-05-01 14:43:32 +0100
commit477c531382353b9d2f1acd90113aeb2df1f63086 (patch)
tree53b06df80cc263fa1bef5a7bb511498d15c636c0 /sys-cluster/ceph
parentapp-misc/gramps: drop USE=berkdb entirely (diff)
downloadgentoo-477c531382353b9d2f1acd90113aeb2df1f63086.tar.gz
gentoo-477c531382353b9d2f1acd90113aeb2df1f63086.tar.bz2
gentoo-477c531382353b9d2f1acd90113aeb2df1f63086.zip
sys-cluster/ceph: fix Python dep harder harder
Closes: https://github.com/gentoo/gentoo/pull/30821 Fixes: 34afa8e8efeaca295954dbf844d9ab46f7b9e2e6 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster/ceph')
-rw-r--r--sys-cluster/ceph/ceph-16.2.10-r5.ebuild5
-rw-r--r--sys-cluster/ceph/ceph-16.2.12.ebuild5
2 files changed, 4 insertions, 6 deletions
diff --git a/sys-cluster/ceph/ceph-16.2.10-r5.ebuild b/sys-cluster/ceph/ceph-16.2.10-r5.ebuild
index d2bc739d6664..21986001fb73 100644
--- a/sys-cluster/ceph/ceph-16.2.10-r5.ebuild
+++ b/sys-cluster/ceph/ceph-16.2.10-r5.ebuild
@@ -93,7 +93,7 @@ DEPEND="
spdk? ( dev-util/cunit )
sqlite? ( dev-db/sqlite:= )
system-boost? ( dev-libs/boost:=[context,python,${PYTHON_USEDEP},zlib] )
- !system-boost? ( $(python_gen_impl_dep '' 3.10 3.11) )
+ !system-boost? ( $(python_gen_impl_dep '' 3.10) )
uring? ( sys-libs/liburing:= )
xfs? ( sys-fs/xfsprogs:= )
zbd? ( sys-block/libzbd:= )
@@ -176,7 +176,6 @@ REQUIRED_USE="
mgr? ( cephfs )
rabbitmq? ( radosgw )
!system-boost? (
- python_targets_python3_9
python_targets_python3_10
)
"
@@ -236,7 +235,7 @@ pkg_pretend() {
pkg_setup() {
if ! use system-boost; then
- python_setup 3.10 3.11
+ python_setup 3.10
else
python_setup
fi
diff --git a/sys-cluster/ceph/ceph-16.2.12.ebuild b/sys-cluster/ceph/ceph-16.2.12.ebuild
index c5d5962caa2b..ba1827895dec 100644
--- a/sys-cluster/ceph/ceph-16.2.12.ebuild
+++ b/sys-cluster/ceph/ceph-16.2.12.ebuild
@@ -93,7 +93,7 @@ DEPEND="
spdk? ( dev-util/cunit )
sqlite? ( dev-db/sqlite:= )
system-boost? ( dev-libs/boost:=[context,python,${PYTHON_USEDEP},zlib] )
- !system-boost? ( $(python_gen_impl_dep '' 3.10 3.11) )
+ !system-boost? ( $(python_gen_impl_dep '' 3.10) )
uring? ( sys-libs/liburing:= )
xfs? ( sys-fs/xfsprogs:= )
zbd? ( sys-block/libzbd:= )
@@ -176,7 +176,6 @@ REQUIRED_USE="
mgr? ( cephfs )
rabbitmq? ( radosgw )
!system-boost? (
- python_targets_python3_9
python_targets_python3_10
)
"
@@ -234,7 +233,7 @@ pkg_pretend() {
pkg_setup() {
if ! use system-boost; then
- python_setup 3.10 3.11
+ python_setup 3.10
else
python_setup
fi