summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-03-25 18:49:58 -0400
committerMike Gilbert <floppym@gentoo.org>2017-03-25 18:49:58 -0400
commitbd7f42bc7d04d73bf85f15a637498e7ce74cb21c (patch)
tree1225f84df4afb87d088146db1d433cd415837138 /sys-boot/efibootmgr/efibootmgr-15.ebuild
parentsys-libs/efivar: remove old (diff)
downloadgentoo-bd7f42bc7d04d73bf85f15a637498e7ce74cb21c.tar.gz
gentoo-bd7f42bc7d04d73bf85f15a637498e7ce74cb21c.tar.bz2
gentoo-bd7f42bc7d04d73bf85f15a637498e7ce74cb21c.zip
sys-boot/efibootmgr: bump to 15
Package-Manager: Portage-2.3.5_p2, Repoman-2.3.2_p32
Diffstat (limited to 'sys-boot/efibootmgr/efibootmgr-15.ebuild')
-rw-r--r--sys-boot/efibootmgr/efibootmgr-15.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-boot/efibootmgr/efibootmgr-15.ebuild b/sys-boot/efibootmgr/efibootmgr-15.ebuild
new file mode 100644
index 000000000000..24116a1cba1f
--- /dev/null
+++ b/sys-boot/efibootmgr/efibootmgr-15.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="User-space application to modify the EFI boot manager"
+HOMEPAGE="https://github.com/rhinstaller/efibootmgr"
+SRC_URI="https://github.com/rhinstaller/efibootmgr/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/pciutils
+ >=sys-libs/efivar-25:="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i -e s/-Werror// Make.defaults || die
+}
+
+src_configure() {
+ tc-export CC
+ export EFIDIR="Gentoo"
+}