summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2022-10-05 15:34:35 +0200
committerFabian Groffen <grobian@gentoo.org>2022-10-05 15:35:21 +0200
commitbb304c378f5ce8c1e297c345f55b69d5541358f0 (patch)
treea743edd85bf5ee154c7c6c2bd3fab1bc9296bf0e /sys-auth/pam_ssh_agent_auth
parentprofiles: mask portage-3.0.37, portage-3.0.38 too (diff)
downloadgentoo-bb304c378f5ce8c1e297c345f55b69d5541358f0.tar.gz
gentoo-bb304c378f5ce8c1e297c345f55b69d5541358f0.tar.bz2
gentoo-bb304c378f5ce8c1e297c345f55b69d5541358f0.zip
sys-auth/pam_ssh_agent_auth-0.10.4: fix build for musl #874843
Closes: https://bugs.gentoo.org/874843 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'sys-auth/pam_ssh_agent_auth')
-rw-r--r--sys-auth/pam_ssh_agent_auth/pam_ssh_agent_auth-0.10.4.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-auth/pam_ssh_agent_auth/pam_ssh_agent_auth-0.10.4.ebuild b/sys-auth/pam_ssh_agent_auth/pam_ssh_agent_auth-0.10.4.ebuild
index d633a44c02ec..d09b0fea56c1 100644
--- a/sys-auth/pam_ssh_agent_auth/pam_ssh_agent_auth-0.10.4.ebuild
+++ b/sys-auth/pam_ssh_agent_auth/pam_ssh_agent_auth-0.10.4.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools toolchain-funcs pam
+inherit autotools toolchain-funcs pam flag-o-matic
DESCRIPTION="Simple module to authenticate users against their ssh-agent keys"
HOMEPAGE="http://pamsshagentauth.sourceforge.net"
@@ -52,6 +52,9 @@ src_prepare() {
src_configure() {
pammod_hide_symbols
+ # bug #874843, use POSIX type names
+ use elibc_musl && append-cppflags -Du_char=uint8_t -Du_int=uint32_t
+
# bug #725720
export AR="$(type -P $(tc-getAR))"