summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2018-06-18 22:50:24 -0400
committerMike Frysinger <vapier@gentoo.org>2018-06-18 22:50:24 -0400
commit90944e2f1fc0f02157d17280f5810a413bccd656 (patch)
treee43e637d07d224f6a640cae047b37dcc45c7de56 /sys-apps
parentsys-apps/attr: resture USE=nls support to 2.4.48 (diff)
downloadgentoo-90944e2f1fc0f02157d17280f5810a413bccd656.tar.gz
gentoo-90944e2f1fc0f02157d17280f5810a413bccd656.tar.bz2
gentoo-90944e2f1fc0f02157d17280f5810a413bccd656.zip
sys-apps/attr: add attr/xattr.h include shim #648864
This will let us upgrade attr while other packages get around to fixing their source. Bug: https://bugs.gentoo.org/648864
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/attr/attr-2.4.48-r1.ebuild (renamed from sys-apps/attr/attr-2.4.48.ebuild)9
-rw-r--r--sys-apps/attr/files/attr-2.4.48-perl-5.26.patch10
-rw-r--r--sys-apps/attr/files/xattr-shim.h6
3 files changed, 20 insertions, 5 deletions
diff --git a/sys-apps/attr/attr-2.4.48.ebuild b/sys-apps/attr/attr-2.4.48-r1.ebuild
index 0de153129dfc..96c88984f87d 100644
--- a/sys-apps/attr/attr-2.4.48.ebuild
+++ b/sys-apps/attr/attr-2.4.48-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI="6"
inherit libtool ltprune toolchain-funcs multilib-minimal
@@ -39,7 +39,8 @@ multilib_src_configure() {
local myeconfargs=(
--bindir="${EPREFIX}"/bin
- --enable-shared $(use_enable static-libs static)
+ --enable-shared
+ $(use_enable static-libs static)
$(use_enable nls)
--libexecdir="${EPREFIX}"/usr/$(get_libdir)
$(use_enable debug)
@@ -53,6 +54,10 @@ multilib_src_install() {
if multilib_is_native_abi; then
# we install attr into /bin, so we need the shared lib with it
gen_usr_ldscript -a attr
+
+ # Add a wrapper until people upgrade.
+ insinto /usr/include/attr
+ newins "${FILESDIR}"/xattr-shim.h xattr.h
fi
}
diff --git a/sys-apps/attr/files/attr-2.4.48-perl-5.26.patch b/sys-apps/attr/files/attr-2.4.48-perl-5.26.patch
index 6f3d2a22c140..49b4c1a57665 100644
--- a/sys-apps/attr/files/attr-2.4.48-perl-5.26.patch
+++ b/sys-apps/attr/files/attr-2.4.48-perl-5.26.patch
@@ -1,13 +1,17 @@
+From 406eab7aa09da9df787a964d3c152c0bda6e23c4 Mon Sep 17 00:00:00 2001
+From: Troy Dawson <tdawson@redhat.com>
+Date: Mon, 24 Jul 2017 14:42:06 +0200
+Subject: [PATCH attr] test: escape left brace in a regex in test/run
+
... to fix test-suite failure with perl-5.26.0
Bug: https://bugzilla.redhat.com/1473853
-Upstream: http://lists.nongnu.org/archive/html/acl-devel/2017-07/msg00001.html
---
test/run | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/test/run b/test/run
-index 4b1f8d0..07e916c 100755
+index 4b1f8d0d6134..07e916c41947 100755
--- a/test/run
+++ b/test/run
@@ -106,7 +106,7 @@ for (;;) {
@@ -20,4 +24,4 @@ index 4b1f8d0..07e916c 100755
if (defined $line) {
if ($line =~ s/^\s*< ?//) {
--
-2.13.0 \ No newline at end of file
+2.16.1
diff --git a/sys-apps/attr/files/xattr-shim.h b/sys-apps/attr/files/xattr-shim.h
new file mode 100644
index 000000000000..818b4c1690c7
--- /dev/null
+++ b/sys-apps/attr/files/xattr-shim.h
@@ -0,0 +1,6 @@
+/* Small shim until we update all packages. */
+#ifndef __XATTR_H__
+#define __XATTR_H__
+#include <sys/xattr.h>
+#warning "Please change your <attr/xattr.h> includes to <sys/xattr.h>"
+#endif