summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-07-15 22:58:26 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-07-15 23:13:59 +0200
commit5c19597cd522622e5a2102d73d83f178e15830a0 (patch)
tree6cb29a067478c5e12b3f9f86a5912bb1dc8a1a66 /sys-apps/superdiag
parentsys-apps/smcipmitool: drop 2.27.1.221101 (diff)
downloadgentoo-5c19597cd522622e5a2102d73d83f178e15830a0.tar.gz
gentoo-5c19597cd522622e5a2102d73d83f178e15830a0.tar.bz2
gentoo-5c19597cd522622e5a2102d73d83f178e15830a0.zip
sys-apps/superdiag: add 1.8.0.20230310
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/superdiag')
-rw-r--r--sys-apps/superdiag/Manifest1
-rw-r--r--sys-apps/superdiag/superdiag-1.8.0.20230310.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/sys-apps/superdiag/Manifest b/sys-apps/superdiag/Manifest
index 9186a7a4e622..7811be8a7218 100644
--- a/sys-apps/superdiag/Manifest
+++ b/sys-apps/superdiag/Manifest
@@ -1 +1,2 @@
DIST SuperDiag_1.6.0_20211224.zip 4669254 BLAKE2B b1b8c55d897bdcba219707a7bf76c802637215754291a78582c4d36441c375386b059ddbb8f27e7ad2cc0c86d9b68fdbea950120c8feed9e63c87a85f5d15181 SHA512 5559d3854d6a3f7ae6426a271b6bc8716ff9cf41c39f32fe23ee3cd2166946b778fe61b1f5ae8838efb2104b427423fa5b2a57c8734147478853290712ddea00
+DIST SuperDiag_1.8.0_20230310.zip 6194537 BLAKE2B 8bc24c90061dd7daa28498867ebc7f88efbead87aa610f32d5e6aeabf28b58bc9b2545030f30302f28cc255c50d0c25ec782d58d7df9d1d5616f050675df16c3 SHA512 d7226db83a08d8a5366e722c94f10492021db08a36695b0bd085acb1b48eeb4461b0a007d017d0d5755aeb016b597abfce5b6f83067b85852aea0f25fd02cd72
diff --git a/sys-apps/superdiag/superdiag-1.8.0.20230310.ebuild b/sys-apps/superdiag/superdiag-1.8.0.20230310.ebuild
new file mode 100644
index 000000000000..c570e794a6ea
--- /dev/null
+++ b/sys-apps/superdiag/superdiag-1.8.0.20230310.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_DATE="$(ver_cut 4)"
+MY_PN="SuperDiag"
+MY_PV="$(ver_cut 1-3)"
+
+DESCRIPTION="Provides the capability to determine the health of Supermicro servers components"
+HOMEPAGE="https://www.supermicro.com"
+SRC_URI="https://www.supermicro.com/Bios/sw_download/557/${MY_PN}_${MY_PV}_${MY_DATE}.zip"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="supermicro"
+SLOT="0"
+IUSE="iso usb"
+
+BDEPEND="app-arch/unzip"
+
+RESTRICT="bindist mirror"
+
+src_unpack() {
+ unpack ${A}
+
+ if use iso; then
+ unzip Diagnose_Remotely/ISOFor${MY_PN}_${MY_PV}.zip -d iso || die
+ fi
+
+ if use usb; then
+ unzip Diagnose_Remotely/USBFor${MY_PN}_${MY_PV}.zip -d usb || die
+ fi
+}
+
+src_install() {
+ insinto /usr/share/superdiag
+ doins startup.nsh ${MY_PN}.efi EFI/Boot/BootX64.efi
+
+ local DOCS=(
+ "Supermicro Super Diagnostics Offline readme.txt"
+ "Supermicro Super Diagnostics Offline User Guide V${MY_PV}.pdf"
+ )
+ dodoc "${DOCS[@]}"
+
+ if use iso; then
+ insinto /usr/share/superdiag/ISO
+ doins iso/${MY_PN}_${MY_PV}.iso
+
+ newdoc iso/Readme.txt Readme.ISO.txt
+ fi
+
+ if use usb; then
+ insinto /usr/share/superdiag/USB
+ doins usb/startup.nsh
+
+ dosym ../BootX64.efi /usr/share/superdiag/USB/BootX64.efi
+ dosym ../${MY_PN}.efi /usr/share/superdiag/USB/${MY_PN}.efi
+
+ newdoc usb/Readme.txt Readme.USB.txt
+ fi
+}