summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@aarsen.me>2022-01-04 11:45:05 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-01-04 11:58:48 +0100
commitb29a56487f6fd949fde8f48194eae363a9d06a60 (patch)
tree12f79967128e9489c53447f360a4b2459d83bac7 /sys-apps/plocate
parentapp-emacs/yatex: Version bump to 1.82 (diff)
downloadgentoo-b29a56487f6fd949fde8f48194eae363a9d06a60.tar.gz
gentoo-b29a56487f6fd949fde8f48194eae363a9d06a60.tar.bz2
gentoo-b29a56487f6fd949fde8f48194eae363a9d06a60.zip
sys-apps/plocate: bump to 1.14
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Arsen Arsenović <arsen@aarsen.me> Closes: https://github.com/gentoo/gentoo/pull/23648 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-apps/plocate')
-rw-r--r--sys-apps/plocate/Manifest1
-rw-r--r--sys-apps/plocate/plocate-1.1.14.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/sys-apps/plocate/Manifest b/sys-apps/plocate/Manifest
index dab6be579d4c..2bcfb43b4f0b 100644
--- a/sys-apps/plocate/Manifest
+++ b/sys-apps/plocate/Manifest
@@ -1,3 +1,4 @@
DIST plocate-1.1.10.tar.gz 72222 BLAKE2B 2d84177454380c9e806a46a6e7057aca15b65c9d83179ba35062d0b8772e7cb3ff50d594c294d73157e7705d4b2eea3f12d07e614076e6a6c7a9b532f42640f5 SHA512 eee4a8982b8fff18793cd06c35cdea501226fae6409df02e8bed3d14feb3ed4ba6c29e907f36f5efb74202e8926547def83379b03aeb6348e1a6e7b51f12fdb9
DIST plocate-1.1.11.tar.gz 72366 BLAKE2B 2b945b3e61244670e2295e1e5abc2af65d2cdbb2393a96961cd4ae97384a735c327037771e6f41927cec0860207a6f98b7b0c2b03d08678bdb0d72a94dfa04f7 SHA512 59f88a11ebbac5f350acca6d1a5890ac1c1cb10c1de2e4e149df60fc63673eefa7f143b06f79ec4e59c65d435b3e222eba5618c48afab97983d76f56fbe8b433
DIST plocate-1.1.13.tar.gz 72741 BLAKE2B 251c5ff570bda125c839e125eab093e15545beb24e75d29c21f13050fc088653f11ba1acbf4c4f6f6aaca4f134908b8084ad4b1e8b0cad83a1a05e1bc2973cdc SHA512 a7c761e4da169716686f438846587e4bdb6df4de039cd7b4fed455e5f52b8aa235714f0c1059787f65f1553a07929802d0ecda0b26111d4f0f811af96a48cb7d
+DIST plocate-1.1.14.tar.gz 73037 BLAKE2B 032963fa268d31664a8abd38ca501aacda4cfe29c8fd1e41228a4cfd5976174736e8d8f8aa1265de8953ec63211700da73e4cdd3eef42c059a638cdd9cd59379 SHA512 c97c9e4aed785af6bd8c2a30d5d5c7190cb4c513f1d6b66bb2885c9550b4cd39f097fac4bd736c211a921955422d0c27b5f35713f03ebe136450cb724fcfe600
diff --git a/sys-apps/plocate/plocate-1.1.14.ebuild b/sys-apps/plocate/plocate-1.1.14.ebuild
new file mode 100644
index 000000000000..a3e786010409
--- /dev/null
+++ b/sys-apps/plocate/plocate-1.1.14.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info meson systemd
+
+DESCRIPTION="Posting locate is a much faster locate"
+HOMEPAGE="https://plocate.sesse.net/"
+SRC_URI="https://plocate.sesse.net/download/${P}.tar.gz"
+
+# GPL-2 for updatedb
+# GPL-2+ for plocate itself
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="+io-uring"
+
+RDEPEND="
+ acct-group/locate
+ app-arch/zstd:=
+ io-uring? ( sys-libs/liburing:= )
+ !sys-apps/mlocate
+"
+DEPEND="${RDEPEND}"
+
+CONFIG_CHECK="~IO_URING"
+ERROR_IO_URING="required for USE=io-uring"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.10-meson-use-feature-option-for-libiouring.patch
+)
+
+src_prepare() {
+ # We'll install the manpage ourself to locate.1
+ sed -i "/install_man('plocate.1')/d" meson.build || die
+
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dlocategroup=locate
+ -Dinstall_systemd=true
+ -Dinstall_cron=false
+ -Dsystemunitdir="$(systemd_get_systemunitdir)"
+ "$(meson_feature io-uring use_libiouring)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dodoc README NEWS
+ newman "${S}"/${PN}.1 locate.1
+ dosym plocate /usr/bin/locate
+
+ insinto /etc
+ doins "${FILESDIR}"/updatedb.conf
+ doins "${FILESDIR}"/plocate-cron.conf
+ fperms 0644 /etc/{updatedb,plocate-cron}.conf
+
+ insinto /etc/cron.daily
+ # Ensure that the cron file has the same name as the
+ # systemd-timer, to avoid plocate being run twice daily on systems
+ # with a systemd compatiblity layer. See also bug #780351.
+ newins "${FILESDIR}"/plocate.cron plocate-updatedb
+ fperms 0755 /etc/cron.daily/plocate-updatedb
+
+ systemd_dounit "${BUILD_DIR}"/${PN}-updatedb.service "${S}"/${PN}-updatedb.timer
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]] ; then
+ elog "The database for the locate command is generated daily by a cron job,"
+ elog "if you install for the first time you can run the updatedb command manually now."
+ elog
+ elog "Note that the ${EROOT}/etc/updatedb.conf file is generic,"
+ elog "please customize it to your system requirements."
+ fi
+}