summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2024-12-09 16:09:29 -0500
committerMike Gilbert <floppym@gentoo.org>2024-12-09 16:14:35 -0500
commiteb6244e0d892a15dc661ce53816c8a68e17c07a2 (patch)
tree504e00df4089f6e537b654d9a4554b7a70ddaad6 /sys-apps/kexec-tools
parentsys-apps/kexec-tools: move CCASFLAGS handling to src_configure (diff)
downloadgentoo-eb6244e0d892a15dc661ce53816c8a68e17c07a2.tar.gz
gentoo-eb6244e0d892a15dc661ce53816c8a68e17c07a2.tar.bz2
gentoo-eb6244e0d892a15dc661ce53816c8a68e17c07a2.zip
sys-apps/kexec-tools: remove purgatory CFLAGS logic
This apparently breaks purgatory with -march=native, etc. Closes: https://bugs.gentoo.org/926536 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/kexec-tools')
-rw-r--r--sys-apps/kexec-tools/kexec-tools-9999.ebuild20
1 files changed, 0 insertions, 20 deletions
diff --git a/sys-apps/kexec-tools/kexec-tools-9999.ebuild b/sys-apps/kexec-tools/kexec-tools-9999.ebuild
index da2ab8cd8928..d0255bda1bc6 100644
--- a/sys-apps/kexec-tools/kexec-tools-9999.ebuild
+++ b/sys-apps/kexec-tools/kexec-tools-9999.ebuild
@@ -44,9 +44,6 @@ PATCHES=(
src_prepare() {
default
- # Append PURGATORY_EXTRA_CFLAGS flags set by configure, instead of overriding them completely.
- sed -e "/^PURGATORY_EXTRA_CFLAGS =/s/=/+=/" -i Makefile.in || die
-
if [[ "${PV}" == 9999 ]] ; then
eautoreconf
else
@@ -67,23 +64,6 @@ src_configure() {
econf "${myeconfargs[@]}"
}
-src_compile() {
- # Respect CFLAGS for purgatory.
- # purgatory/Makefile uses PURGATORY_EXTRA_CFLAGS variable.
- # -mfunction-return=thunk and -mindirect-branch=thunk conflict with
- # -mcmodel=large which is added by build system.
- # Replace them with -mfunction-return=thunk-inline and -mindirect-branch=thunk-inline.
- local flag flags=()
- for flag in ${CFLAGS}; do
- [[ ${flag} == -mfunction-return=thunk ]] && flag="-mfunction-return=thunk-inline"
- [[ ${flag} == -mindirect-branch=thunk ]] && flag="-mindirect-branch=thunk-inline"
- flags+=("${flag}")
- done
- local -x PURGATORY_EXTRA_CFLAGS="${flags[*]}"
-
- default
-}
-
src_install() {
default