summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2019-12-07 16:20:52 +0100
committerConrad Kostecki <conikost@gentoo.org>2019-12-07 16:46:29 +0100
commit8dfea140166419c3416bddb2bf590e8ebb86d343 (patch)
treed821bee34fc737cb008282377f2094a1fa82c9d1 /sys-apps/edid-decode
parentmedia-sound/flacon: RESTRICT="!test? ( test )" (diff)
downloadgentoo-8dfea140166419c3416bddb2bf590e8ebb86d343.tar.gz
gentoo-8dfea140166419c3416bddb2bf590e8ebb86d343.tar.bz2
gentoo-8dfea140166419c3416bddb2bf590e8ebb86d343.zip
sys-apps/edid-decode: New package
Decodes EDID monitor description data in human-readable format. Closes: https://bugs.gentoo.org/669720 Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/edid-decode')
-rw-r--r--sys-apps/edid-decode/Manifest1
-rw-r--r--sys-apps/edid-decode/edid-decode-0_pre20191207.ebuild35
-rw-r--r--sys-apps/edid-decode/edid-decode-9999.ebuild31
-rw-r--r--sys-apps/edid-decode/metadata.xml15
4 files changed, 82 insertions, 0 deletions
diff --git a/sys-apps/edid-decode/Manifest b/sys-apps/edid-decode/Manifest
new file mode 100644
index 000000000000..14380c27fd31
--- /dev/null
+++ b/sys-apps/edid-decode/Manifest
@@ -0,0 +1 @@
+DIST edid-decode-0_pre20191207.tar.gz 56644 BLAKE2B 85869293a3f47558f0e1c7dc22e482299cfa19ad62bb4801aa03f303a7f4e63f4a8424fdd177fbc9aa510183283322d68b519e8436648d763e7b983e490a39e4 SHA512 bbbf98394409f6bb043e67be0a91b4aa0a596b3f10d5e8b033597fac723b98df3b57e5ecc591a5dcb768eb98cae8390474000fb67ca82cf25d617652bd835ba1
diff --git a/sys-apps/edid-decode/edid-decode-0_pre20191207.ebuild b/sys-apps/edid-decode/edid-decode-0_pre20191207.ebuild
new file mode 100644
index 000000000000..782193f55c43
--- /dev/null
+++ b/sys-apps/edid-decode/edid-decode-0_pre20191207.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+EGIT_COMMIT="46a0691551e44d49a2c3951a7d944786131c97c3"
+MY_P="${PN}-${EGIT_COMMIT}"
+
+DESCRIPTION="Decode EDID data in a human-readable format"
+HOMEPAGE="https://git.linuxtv.org/edid-decode.git/"
+SRC_URI="https://dev.gentoo.org/~conikost/files/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ tc-export CXX
+ default
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ einstalldocs
+
+ if use examples; then
+ insinto /usr/share/edid-decode/examples
+ doins data/*
+ fi
+}
diff --git a/sys-apps/edid-decode/edid-decode-9999.ebuild b/sys-apps/edid-decode/edid-decode-9999.ebuild
new file mode 100644
index 000000000000..8e35fcbc1324
--- /dev/null
+++ b/sys-apps/edid-decode/edid-decode-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3 toolchain-funcs
+
+EGIT_REPO_URI="https://git.linuxtv.org/${PN}.git"
+
+DESCRIPTION="Decode EDID data in a human-readable format"
+HOMEPAGE="https://git.linuxtv.org/edid-decode.git/"
+
+KEYWORDS=""
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+src_compile() {
+ tc-export CXX
+ default
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ einstalldocs
+
+ if use examples; then
+ insinto /usr/share/edid-decode/examples
+ doins data/*
+ fi
+}
diff --git a/sys-apps/edid-decode/metadata.xml b/sys-apps/edid-decode/metadata.xml
new file mode 100644
index 000000000000..207a2c8a4f1d
--- /dev/null
+++ b/sys-apps/edid-decode/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <longdescription>
+ Decodes EDID monitor description data in human-readable format.
+ If invoked with no arguments it reads from standard input and writes to standard output.
+ With one argument, the file named by the argument is read instead.
+ With two arguments, normal output is suppressed, and the binary EDID blob is
+ written to the file named by the second argument.
+ </longdescription>
+</pkgmetadata>