summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2023-12-25 20:03:36 +1100
committerSam James <sam@gentoo.org>2023-12-25 09:53:38 +0000
commitc60360ea86b68913f5fcf4ece9d80e415f8eb2ed (patch)
tree956eb7e332c7c0079e5110e7cf2d7a82703c1d23 /sys-apps/dbus-broker/dbus-broker-35.ebuild
parentdev-ruby/json: add 2.7.1 (diff)
downloadgentoo-c60360ea86b68913f5fcf4ece9d80e415f8eb2ed.tar.gz
gentoo-c60360ea86b68913f5fcf4ece9d80e415f8eb2ed.tar.bz2
gentoo-c60360ea86b68913f5fcf4ece9d80e415f8eb2ed.zip
sys-apps/dbus-broker: add 35
Closes: https://bugs.gentoo.org/920372 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/dbus-broker/dbus-broker-35.ebuild')
-rw-r--r--sys-apps/dbus-broker/dbus-broker-35.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-apps/dbus-broker/dbus-broker-35.ebuild b/sys-apps/dbus-broker/dbus-broker-35.ebuild
new file mode 100644
index 000000000000..5a5836b5b997
--- /dev/null
+++ b/sys-apps/dbus-broker/dbus-broker-35.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2017-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bus1/dbus-broker.git"
+else
+ SRC_URI="https://github.com/bus1/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+fi
+
+DESCRIPTION="Linux D-Bus Message Broker"
+HOMEPAGE="https://github.com/bus1/dbus-broker/wiki"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="apparmor audit doc +launcher selinux"
+
+DEPEND="
+ apparmor? (
+ >=sys-libs/libapparmor-3.0
+ )
+ audit? (
+ >=sys-process/audit-3.0
+ >=sys-libs/libcap-ng-0.6
+ )
+ launcher? (
+ >=dev-libs/expat-2.2
+ >=sys-apps/systemd-230:0=
+ )
+ selinux? ( >=sys-libs/libselinux-3.2 )
+"
+RDEPEND="${DEPEND}
+ launcher? ( sys-apps/dbus )"
+BDEPEND="
+ doc? ( dev-python/docutils )
+ virtual/pkgconfig
+"
+
+if [[ ${PV} == 9999 ]]; then
+src_unpack() {
+ git-r3_src_unpack
+ cd "${P}" || die
+ meson subprojects download || die
+}
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use apparmor)
+ $(meson_use audit)
+ $(meson_use doc docs)
+ $(meson_use launcher)
+ $(meson_use selinux)
+ )
+ meson_src_configure
+}