summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-11-02 12:52:42 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-11-02 13:05:46 +0100
commit5f863eff92cc653c85e5051a860d28abfb4c2a32 (patch)
tree5cd05370869e55332f2e512148c3baa29057e959 /sys-apps/cpuid
parentsys-auth/AusweisApp: add 2.2.2 (diff)
downloadgentoo-5f863eff92cc653c85e5051a860d28abfb4c2a32.tar.gz
gentoo-5f863eff92cc653c85e5051a860d28abfb4c2a32.tar.bz2
gentoo-5f863eff92cc653c85e5051a860d28abfb4c2a32.zip
sys-apps/cpuid: add 20241023
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/cpuid')
-rw-r--r--sys-apps/cpuid/Manifest1
-rw-r--r--sys-apps/cpuid/cpuid-20241023.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/cpuid/Manifest b/sys-apps/cpuid/Manifest
index dd6fb3c15f18..9aeb98cc7d67 100644
--- a/sys-apps/cpuid/Manifest
+++ b/sys-apps/cpuid/Manifest
@@ -1 +1,2 @@
DIST cpuid-20240916.src.tar.gz 157553 BLAKE2B 2f5ef3264fcc647122a73edf9a2b39110c11a23ac366c99481ec8cec4d7108ce088847b485f6b8e7dece757fb0246bafbbbaad36d0dc8128ade3290988a1f7de SHA512 f78e36400a963d39fb9d1b6dab6d79ea1ab700912aa229a4efc2088e61964fb5ece52c2204fadd34f1f75cfab6f7b659288c8892b86c44568e784283bf3f5278
+DIST cpuid-20241023.src.tar.gz 160816 BLAKE2B de3c5750e8bd90882ac3a13ad81196b0287bd2ee321c54adda18a754e128f9c72b72177874c652ccb02d17ace336c70705c899f3e6493e7f4c655a9f992114ef SHA512 81d4b4de609365fb801d785fab9c4f190885569fa97db10ab5e8f7e227a335313c0bafb02696a0bb1d14d11c49e90979a2b9b60eb970e6d7c617be99142a941b
diff --git a/sys-apps/cpuid/cpuid-20241023.ebuild b/sys-apps/cpuid/cpuid-20241023.ebuild
new file mode 100644
index 000000000000..c2868c0d5525
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20241023.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux tool to dump x86 CPUID information about the CPUs"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+BDEPEND="
+ app-alternatives/gzip
+ dev-lang/perl
+"
+
+DOCS=( "ChangeLog" "FUTURE" )
+
+PATCHES=( "${FILESDIR}/${PN}-20220620-makefile.patch" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+
+ einstalldocs
+}