summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2024-11-07 18:14:08 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2024-11-25 08:55:53 +0100
commit8998e9cd25f7eba6d4e1198f7942be5b885a4836 (patch)
treec84aec27f8e05649746bffd5334e124ab2591756 /sci-visualization
parentdev-java/commons-io: add 2.18.0 (diff)
downloadgentoo-8998e9cd25f7eba6d4e1198f7942be5b885a4836.tar.gz
gentoo-8998e9cd25f7eba6d4e1198f7942be5b885a4836.tar.bz2
gentoo-8998e9cd25f7eba6d4e1198f7942be5b885a4836.zip
sci-visualization/gcalc: style update, update EAPI 7 -> 8
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/39233/commits/5fe47fd0f9be63794fc52a4875262833da20f49c Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/gcalc/gcalc-3.1_rc1-r3.ebuild (renamed from sci-visualization/gcalc/gcalc-3.1_rc1-r2.ebuild)31
1 files changed, 15 insertions, 16 deletions
diff --git a/sci-visualization/gcalc/gcalc-3.1_rc1-r2.ebuild b/sci-visualization/gcalc/gcalc-3.1_rc1-r3.ebuild
index f5a27970376f..825f3b99f106 100644
--- a/sci-visualization/gcalc/gcalc-3.1_rc1-r2.ebuild
+++ b/sci-visualization/gcalc/gcalc-3.1_rc1-r3.ebuild
@@ -1,38 +1,37 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit desktop java-pkg-2 java-pkg-simple
MY_P="GCalc-${PV/_/-}"
DESCRIPTION="Java Mathematical Graphing System"
-HOMEPAGE="http://gcalc.net/"
-SRC_URI="http://gcalc.net/files/${MY_P}.tar.gz"
+HOMEPAGE="https://gcalc.net/"
+SRC_URI="https://gcalc.net/files/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
-KEYWORDS="~amd64"
SLOT="0"
+KEYWORDS="~amd64"
-RDEPEND=">=virtual/jre-1.8:*"
DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
-S="${WORKDIR}/${MY_P}"
+JAVA_MAIN_CLASS="net.gcalc.calc.GCalc"
+JAVA_RESOURCE_DIRS="res"
+JAVA_SRC_DIR="src"
src_prepare() {
+ java-pkg-2_src_prepare
java-pkg_clean
- default
-}
-
-src_compile() {
- java-pkg-simple_src_compile
- java-pkg_addres ${PN}.jar src ! -name "*.html"
+ mkdir res || die
+ mv {src,res}/resources || die
+ cp {src,res}/pluginlist.xml || die
}
src_install() {
java-pkg-simple_src_install
- java-pkg_dolauncher gcalc --main net.gcalc.calc.GCalc
-
- newicon src/resources/gicon.png ${PN}.png
+ newicon res/resources/gicon.png ${PN}.png
make_desktop_entry ${PN} "GCalc Java Mathematical Graphing System"
}