summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-12-26 11:17:30 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-12-26 12:48:35 -0500
commitc08bd80c7767e50558567b6469286d2b2a9cca03 (patch)
tree78a84b9f4b72273b5a6a1dd25b1e5362053f643d /sci-visualization/spyview/spyview-2018.12.24.ebuild
parentsci-mathematics/octave: update fltk[xft] USE dep (diff)
downloadgentoo-c08bd80c7767e50558567b6469286d2b2a9cca03.tar.gz
gentoo-c08bd80c7767e50558567b6469286d2b2a9cca03.tar.bz2
gentoo-c08bd80c7767e50558567b6469286d2b2a9cca03.zip
sci-visualization/spyview: add binding := to fltk & fix build with 1.4
1.4.x drops the case sensitivity compat symlinks by default and upstream strongly recommends to fix packages rather than re-enable them. := due to new soname Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'sci-visualization/spyview/spyview-2018.12.24.ebuild')
-rw-r--r--sci-visualization/spyview/spyview-2018.12.24.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/sci-visualization/spyview/spyview-2018.12.24.ebuild b/sci-visualization/spyview/spyview-2018.12.24.ebuild
deleted file mode 100644
index 6dcdb79c891f..000000000000
--- a/sci-visualization/spyview/spyview-2018.12.24.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic
-
-DESCRIPTION="2D and 3D data visualization and analysis program"
-HOMEPAGE="https://github.com/gsteele13/spyview"
-
-if [[ ${PV} == *9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/gsteele13/spyview.git"
-else
- SRC_URI="https://github.com/gsteele13/spyview/archive/710b9ddb6aa00fada1a758d42b57b75f92bb32a7.tar.gz -> ${P}.tgz"
- KEYWORDS="amd64 ~x86"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-
-COMMON_DEPEND="
- dev-libs/boost:=
- media-libs/netpbm
- x11-libs/fltk:1[opengl]
- app-text/ghostscript-gpl
- virtual/glu
-"
-
-DEPEND="${COMMON_DEPEND}
- sys-apps/groff"
-
-RDEPEND="${COMMON_DEPEND}
- sci-visualization/gnuplot"
-
-PATCHES=(
- "${FILESDIR}/spyview-no-user-dirs.patch"
-)
-
-src_unpack() {
- if [[ ${PV} == *9999* ]] ; then
- git-r3_src_unpack
- S="${WORKDIR}/${P}/source"
- else
- default
- mv -v "${WORKDIR}"/spyview-*/source "${S}" || die
- fi
-}
-
-src_prepare() {
- append-cflags $(fltk-config --cflags)
- append-cxxflags $(fltk-config --cxxflags)
-
- append-cxxflags -std=c++14
-
- append-cppflags -I"${EPREFIX}"/usr/include/netpbm
-
- # append-ldflags $(fltk-config --ldflags)
- # this one leads to an insane amount of warnings
- append-ldflags -L$(dirname $(fltk-config --libs))
-
- while IFS="" read -d $'\0' -r file; do
- sed -i -e 's:-mwindows -mconsole::g' "$file" || die
- done < <(find "${S}" -name Makefile.am -print0)
-
- if [[ ${PV} == *9999* ]] ; then
- eapply_user
- else
- default
- fi
- eautoreconf
-}