summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-04-10 19:47:59 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-04-10 20:49:23 +0200
commitd11706013713929a25850c2afe7544d13633fd92 (patch)
tree46bedd1aa2690cd7aeb03a16f72dc9036760492d /sci-mathematics
parentsci-mathematics/gappalib-coq: bump to 1.5.3 (diff)
downloadgentoo-d11706013713929a25850c2afe7544d13633fd92.tar.gz
gentoo-d11706013713929a25850c2afe7544d13633fd92.tar.bz2
gentoo-d11706013713929a25850c2afe7544d13633fd92.zip
sci-mathematics/coq-serapi: bump to 0.17.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/coq-serapi/Manifest1
-rw-r--r--sci-mathematics/coq-serapi/coq-serapi-0.17.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/sci-mathematics/coq-serapi/Manifest b/sci-mathematics/coq-serapi/Manifest
index bb04f4922260..427eaa5dae04 100644
--- a/sci-mathematics/coq-serapi/Manifest
+++ b/sci-mathematics/coq-serapi/Manifest
@@ -1,3 +1,4 @@
DIST coq-serapi-0.16.1.tar.gz 271068 BLAKE2B 5e832f4b2d2627938f2399b3eff111a15987d7733e30ba6f6328dc0110631a1c42a212c5ed464037f8c521c11c46bf8bb8665bfdd93b5969949cdec584a42e18 SHA512 348a984897f99dd4f08a409251eaf50f792aa1fe96d71d5f895f3153c05131b2d6b15f10a18cf704e978676562547d0869a310e8d6969ffe69d5bdf1c212b756
DIST coq-serapi-0.16.2.tar.gz 272807 BLAKE2B 20a04ae8b18fba7c6d8346515d4f610750e32e6a521dc65afd7a624ae07ddea75b4f8aed237ba95ed16667f3867b35dd914b35eab966187f6f41f547f3bac8d6 SHA512 f7aba7009f14302246eabe595af7cb72103b8904e45c647783326f46d51b1331b30dd515364c4b909f02c42c5bf7bd367dc0fe64eb9c88b062cd79113b53306b
DIST coq-serapi-0.16.3.tar.gz 272910 BLAKE2B e3e5e070e98d9dd41d3b7ef589abcb57137925ed637be7c94aaa387dbe996ce72d4c98f37b6e8ee9ca196af6deb291afbb326ac6aeb8c1809331bbc1824a0786 SHA512 fccc946d87de4fbe797df6a898704ead04708323bdf3b799ced074ba1539d7d5b54d3cc439f7641fe3bf289069ca42278137a10c8de211b1563df9b6a61ad8c5
+DIST coq-serapi-0.17.0.tar.gz 273903 BLAKE2B 155d865650f773d71e0ddd10869852916de5e539b3b3f4d03d58259790482be45d668035975d5be768776f7ef5947f0d7227f0f6624bc7f64cefd009e9a83ecb SHA512 d9085b4215c233c47f78386d8771348768c9cbbf0716dfa4da3ff8c8c96d2e78b203098314175ef2bb9959096f8b0ec03a9fb5d696d0451eeee0713bd48afa2b
diff --git a/sci-mathematics/coq-serapi/coq-serapi-0.17.0.ebuild b/sci-mathematics/coq-serapi/coq-serapi-0.17.0.ebuild
new file mode 100644
index 000000000000..2485ac135a10
--- /dev/null
+++ b/sci-mathematics/coq-serapi/coq-serapi-0.17.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COQ_MIN_V=8.17.0
+COQ_MAX_V=8.18.0
+
+inherit elisp-common dune
+
+DESCRIPTION="Serialization library and protocol for interaction with the Coq proof assistant"
+HOMEPAGE="https://github.com/ejgallego/coq-serapi/"
+
+# The tarball in SRC_URI is comprised of <supported coq>+<package version>
+SRC_URI="https://github.com/ejgallego/${PN}/archive/${COQ_MIN_V}+${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${COQ_MIN_V}-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="emacs +ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=sci-mathematics/coq-${COQ_MIN_V}:= <sci-mathematics/coq-${COQ_MAX_V}:=
+ >=dev-ml/ppx_sexp_conv-0.13.0:=
+ dev-ml/cmdliner:=
+ dev-ml/ppx_compare:=
+ dev-ml/ppx_deriving:=
+ dev-ml/ppx_deriving_yojson:=
+ dev-ml/ppx_hash:=
+ dev-ml/ppx_import:=
+ dev-ml/sexplib:=
+ dev-ml/yojson:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ emacs? ( >=app-editors/emacs-23.1:* )
+ test? ( sci-mathematics/coq-mathcomp )
+"
+
+SITEFILE="50sertop-gentoo.el"
+
+PATCHES=( "${FILESDIR}"/${PN}-sertop.el-path.patch )
+
+src_compile() {
+ dune_src_compile
+
+ use emacs && elisp-compile sertop.el
+}
+
+src_install() {
+ dune_src_install
+
+ rm -r "${D}"/usr/share/emacs || die
+
+ if use emacs ; then
+ elisp-install ${PN} sertop.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}