summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-09-20 20:47:49 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-09-20 20:59:34 -0400
commitb38e0a0b22acc859251d038b55ee73c676fcf8e6 (patch)
tree050990f94e27787ec57a7379491beeb9e23dbaeb /sci-mathematics
parentapp-admin/consul: drop 1.12.4, 1.13.1 (diff)
downloadgentoo-b38e0a0b22acc859251d038b55ee73c676fcf8e6.tar.gz
gentoo-b38e0a0b22acc859251d038b55ee73c676fcf8e6.tar.bz2
gentoo-b38e0a0b22acc859251d038b55ee73c676fcf8e6.zip
sci-mathematics/pari: bullet-proof DLLD detection.
We have another DLLD (compiler driver for shared libraries) detection issue in bug 871117. We now force DLLD=$CC during ./Configure, which should override the detection with the correct value more reliably. Closes: https://bugs.gentoo.org/871117 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/pari/pari-2.15.0.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/sci-mathematics/pari/pari-2.15.0.ebuild b/sci-mathematics/pari/pari-2.15.0.ebuild
index 38356d9374b4..212fed3f24df 100644
--- a/sci-mathematics/pari/pari-2.15.0.ebuild
+++ b/sci-mathematics/pari/pari-2.15.0.ebuild
@@ -74,13 +74,13 @@ src_configure() {
fi
# sysdatadir installs a pari.cfg stuff which is informative only.
- # It is supposed to be for "architecture-dependent" data.
- # It needs to be easily discoverable for downstream packages such as gp2c.
- # We set LD to "" so that it is set to the value of the compiler used
- # which is how a normal end user is expected to configure it. pari's build
- # system do not cope very well with a naked linker, it is expecting a
- # compiler driver. See https://bugs.gentoo.org/722090
- LD="" ./Configure \
+ # It is supposed to be for "architecture-dependent" data. It needs
+ # to be easily discoverable for downstream packages such as gp2c.
+ # We set LD="" and DLLD="$CC" so that the "shared library linker"
+ # always gets set to the value of the compiler used. Pari's build
+ # system does not cope very well with a naked linker, it is
+ # expecting a compiler driver. See bugs 722090 and 871117.
+ LD="" DLLD="$(tc-getCC)" ./Configure \
--prefix="${EPREFIX}"/usr \
--datadir="${EPREFIX}/usr/share/${PN}" \
--libdir="${EPREFIX}/usr/$(get_libdir)" \