summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2018-03-26 13:28:21 +0700
committerAndrey Grozin <grozin@gentoo.org>2018-03-26 13:28:21 +0700
commit62e21bf1fb7b68552dbfa277d32e124bb4f7a23e (patch)
tree998d41ac9643f86e69124564cd8cb26bc996a7be /sci-mathematics
parentsci-mathematics/fricas: cleaning old (diff)
downloadgentoo-62e21bf1fb7b68552dbfa277d32e124bb4f7a23e.tar.gz
gentoo-62e21bf1fb7b68552dbfa277d32e124bb4f7a23e.tar.bz2
gentoo-62e21bf1fb7b68552dbfa277d32e124bb4f7a23e.zip
sci-mathematics/fricas: fix configure for lisps other than sbcl and ccl
Closes: https://bugs.gentoo.org/650788 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/fricas/fricas-1.3.3.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sci-mathematics/fricas/fricas-1.3.3.ebuild b/sci-mathematics/fricas/fricas-1.3.3.ebuild
index 1be321f3f7bd..b844cb78f7b6 100644
--- a/sci-mathematics/fricas/fricas-1.3.3.ebuild
+++ b/sci-mathematics/fricas/fricas-1.3.3.ebuild
@@ -51,7 +51,7 @@ DEPEND="${RDEPEND}"
RESTRICT="strip"
src_configure() {
- local LISP n
+ local LISP n GMP
LISP=sbcl
n=${#LISPS[*]}
for ((n--; n > 0; n--)); do
@@ -64,8 +64,14 @@ src_configure() {
done
einfo "Using lisp: ${LISP}"
+ # bug #650788
+ if [[ ${LISP} = sbcl || ${LISP} = ccl ]]
+ then GMP=$(use_with gmp)
+ else GMP=''
+ fi
+
# aldor is not yet in portage
- econf --disable-aldor --with-lisp=${LISP} $(use_with X x) $(use_with gmp)
+ econf --disable-aldor --with-lisp=${LISP} $(use_with X x) ${GMP}
}
src_compile() {